Subject: oracle_fdw RPMs

From: Alvaro Herrera <[email-masked]>
Date: Thu, 1 Jun 2017 15:54:33 -0400

Hello

I have noticed that the RPMs for oracle_fdw seem not to be generated.  I
see that the src.rpm files are in the repo, but not the binary ones.  Is
this an oversight, or is it intentional?

-- 
Álvaro Herrera                https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 01 Jun 2017 23:35:37 +0300

Hi Alvaro,

> this an oversight, or is it intentional?

The package has these BR:

# Package builder needs to adjust this as needed.
#BuildRequires: oracle-instantclient11.2-basic
#BuildRequires: oracle-instantclient11.2-devel

So, to build binary packages, we need to install these RPMs -- and we don't, because the build server only include open source software.

Cheers,
-- 
Devrim Gündüz
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR