Subject: Problem with PostgreSQL 10 Repo RPM on Oracle Linux 6

From: Jason Petersen <[email-masked]>
Date: Thu, 5 Oct 2017 14:26:28 -0600

Looks like something is wrong with the PGDG repo RPM for PostgreSQL 10 on Oracle Linux 6…

This works fine: yum install -y https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-6-x86_64/pgdg-oraclelinux10-10-2.noarch.rpm

But something is wrong with the URL that gets configured. Subsequent yum commands error out:

https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-6Server-x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: pgdg10. Please verify its path and try again

Comparing https://download.postgresql.org/pub/repos/yum/9.6/redhat/ <https://download.postgresql.org/pub/repos/yum/9.6/redhat/> to https://download.postgresql.org/pub/repos/yum/10/redhat/ <https://download.postgresql.org/pub/repos/yum/10/redhat/>, it appears the problem is the lack of the four rhel-6(Server|Workstation)-(i386|x86_64) folders.

Is this intended? I assume not, but am unfamiliar with why/when releasever is 6Server rather than 6 or 6.9 or something…

--
Jason Petersen
Software Engineer | Citus Data
303.736.9255
[email-masked]

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 06 Oct 2017 00:57:53 +0100

Hi Jason,

On Thu, 2017-10-05 at 14:26 -0600, Jason Petersen wrote:
> This works fine: yum install -y https://download.postgresql.org/pub/repos/yum
> /10/redhat/rhel-6-x86_64/pgdg-oraclelinux10-10-2.noarch.rpm
> 
> https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-6Server-x86_64/r
> epodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned
> error: 404 Not Found"
> Trying other mirror.
> Error: Cannot retrieve repository metadata (repomd.xml) for repository:
> pgdg10. Please verify its path and try again
> 
> Comparing https://download.postgresql.org/pub/repos/yum/9.6/redhat/ <https://
> download.postgresql.org/pub/repos/yum/9.6/redhat/> to https://download.postgr
> esql.org/pub/repos/yum/10/redhat/ <https://download.postgresql.org/pub/repos/
> yum/10/redhat/>, it appears the problem is the lack of the four rhel-
> 6(Server|Workstation)-(i386|x86_64) folders.
> 
> Is this intended? I assume not, but am unfamiliar with why/when releasever is
> 6Server rather than 6 or 6.9 or something…

Thanks for the report and analysis. I created the symlinks. They will appear in
master repo in next 25 mins.

Regards,
 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR