Subject: EL7 postgis24_10 breaks yum upgrade

From: "Liss Tarnell" <[email-masked]>
Date: Sat, 4 Nov 2017 11:38:26 -0000

hello,

after installing pgdg-centos10, postgresql10-server and postgis24_10 on CentOS 7.4, yum upgrade refuses to run due to a dependency issue:

---
Resolving Dependencies
--> Running transaction check
---> Package libgeotiff.x86_64 0:1.2.5-14.el7 will be updated
--> Processing Dependency: libgeotiff.so.1.2()(64bit) for package: gdal-libs-1.11.4-1.el7.x86_64
---> Package libgeotiff.x86_64 0:1.4.0-1.rhel7 will be an update
--> Finished Dependency Resolution
Error: Package: gdal-libs-1.11.4-1.el7.x86_64 (@epel)
           Requires: libgeotiff.so.1.2()(64bit)
           Removing: libgeotiff-1.2.5-14.el7.x86_64 (@epel)
               libgeotiff.so.1.2()(64bit)
           Updated By: libgeotiff-1.4.0-1.rhel7.x86_64 (pgdg10)
               Not found
---

the updated libgeotiff from the PGDG repository doesn't seem to be necessary, so i can exclude that from yum to fix the problem temporarily, but this seems like a problem with the repository, unless i've done something wrong installing it?

	thanks, liss.

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 29 Nov 2017 14:18:12 +0000

Hi,

Apologies for the late response.

I could reproduce the issue. Removed packages from the repo. They will sync to
master repo in 1 hour.

Regards, Devrim

On Sat, 2017-11-04 at 11:38 +0000, Liss Tarnell wrote:
> hello,
> 
> after installing pgdg-centos10, postgresql10-server and postgis24_10 on
> CentOS 7.4, yum upgrade refuses to run due to a dependency issue:
> 
> ---
> Resolving Dependencies
> the updated libgeotiff from the PGDG repository doesn't seem to be necessary,
> so i can exclude that from yum to fix the problem temporarily, but this seems
> like a problem with the repository, unless i've done something wrong
> installing it?
> 
> 	thanks, liss.
> 
> 
> 

-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR