Subject: Rebuild RPM from Source

From: RahulGoutham G S <[email-masked]>
Date: Mon, 8 Jan 2018 16:00:22 -0800

Hello Everyone ,

i am working on rebuilding the postgres RPM from source code (which has
some custom changes) for Cent OS distribution .  I did
find  pgdg-centos-96.spec in /pgrpms/rpm/redhat/9.6/pgdg-yum/CTOS-7
from  git://git.postgresql.org/git/pgrpms.git .

However i dont have any clue how to use these , can you help ? I am
currently able to rebuild the source with my changes but could not figure
out how to package this .

Thanks
Rahul

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 09 Jan 2018 21:41:09 +0300

Hi,

> out how to package this .

make rpm96

will build your package for PostgreSQL 9.6. If you want to sign them, run:

make build96 (assuming you have your gpg keys set up, etc)

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR