Subject: Package dependency issues installing PostGIS 2.4.3

From: Greg Barker <[email-masked]>
Date: Fri, 19 Jan 2018 12:35:08 -0800

Originally posted this on the postgis-users list, but it was suggested to
ask on pgsql-pkg-yum instead:
http://lists.osgeo.org/pipermail/postgis-users/2018-January/042576.html

On a RedHat 7.4 machine, tried to do a "yum install postgres24_96" today
and got the following:

Error: Package: postgis24_96-2.4.3-1.rhel7.x86_64 (pgdg96)
           Requires: libproj.so.12()(64bit)
Error: Package: postgis24_96-2.4.3-1.rhel7.x86_64 (pgdg96)
           Requires: proj49
Error: Package: postgis24_96-2.4.3-1.rhel7.x86_64 (pgdg96)
           Requires: geos36 >= 3.6.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I did the same earlier this week which installed 2.4.2 and it worked fine.

One thing I noticed is that the package size for 2.4.3 is much smaller than
2.4.2:

[user@box1 ~]# yum info postgis24_96
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Available Packages
Name        : postgis24_96
Arch        : x86_64
Version     : 2.4.3
Release     : 1.rhel7
Size        : 6.2 M
Repo        : pgdg96/7Server/x86_64
Summary     : Geographic Information Systems Extensions to PostgreSQL
URL         : http://www.postgis.net/
License     : GPLv2+
Description : PostGIS adds support for geographic objects to the PostgreSQL
object-relational
            : database. In effect, PostGIS "spatially enables" the
PostgreSQL server,
            : allowing it to be used as a backend spatial database for
geographic information
            : systems (GIS), much like ESRI's SDE or Oracle's Spatial
extension. PostGIS
            : follows the OpenGIS "Simple Features Specification for SQL"
and has been
            : certified as compliant with the "Types and Functions" profile.

Versus:

[root@box2 ~]# yum info postgis24_96
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Installed Packages
Name        : postgis24_96
Arch        : x86_64
Version     : 2.4.2
Release     : 1.rhel7
Size        : 101 M
Repo        : installed

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 28 Jan 2018 13:12:31 +0000

Hi,

>  You could try running: rpm -Va --nofiles --nodigest

Sorry for the delay. I fixed this a few days ago.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR