Subject: broken postgis23_95 dependencies on CentOS/RHEL 6

From: James Cassell <[email-masked]>
Date: Tue, 13 Feb 2018 19:50:22 -0500

Hello,

Thanks for creating a yum repo for these packages.  I find it quite useful at work!

Unfortunately, I'm now getting the following error when trying to 'yum install postgis23_95' on a RHEL 6 box:

Error: Package: postgis23_95-2.3.6-2.rhel6.x86_64 (pgdg95)
           Requires: geos36 >= 3.6.2
Error: Package: postgis23_95-2.3.6-2.rhel6.x86_64 (pgdg95)
           Requires: libproj.so.12()(64bit)
Error: Package: postgis23_95-2.3.6-2.rhel6.x86_64 (pgdg95)
           Requires: proj49

If I install the older version, it works fine. ('yum install postgis23_95-2.3.4')  (The changelog says the functional version is 2.3.5, but the RPM says 2.3.4.)

The pgdg95/rhel-6-x86_64 yum repo doesn't have the necessary dependencies for postgis23_95; specifically, the geos36 package is missing and also the proj49 package. The repo does have geos-3.5 and proj-4.8, but the package name doesn't match (also the version).

I see this in the changelog:
postgis23_95-2.3.6-2.rhel6.x86_64        pgdg95
* Sun Jan 28 12:00:00 2018 Devrim Gündüz <> - 2.3.6-2
- Let PostGIS 2.3 depend on PGDG supplied Proj49 and GeOS 36 RPMs.
  This will help users to benefit from latest GeOS and Proj.

The rhel-7-x86_64 version of the repo does have the proj49 and geos36 rpms,
but the rhel-6-x86_64 versions of the repo lacks those RPMs, hence the
issue, and hence why it took a few days to catch this.  (Likely many other people are using CentOS/RHEL 7.)

If there's any other info that would be helpful, please let me know!

Thanks!

V/r,
James Cassell

---

From: James Cassell <[email-masked]>
Date: Thu, 15 Feb 2018 10:36:52 -0500

Thanks for fixing this issue!

V/r,
James Cassell

On Tue, Feb 13, 2018, at 7:50 PM, James Cassell wrote:
> If I install the older version, it works fine. ('yum install 
> postgis23_95-2.3.4')  (The changelog says the functional version is 
> 2.3.5, but the RPM says 2.3.4.)
> 
> The pgdg95/rhel-6-x86_64 yum repo doesn't have the necessary 
> dependencies for postgis23_95; specifically, the geos36 package is 
> missing and also the proj49 package. The repo does have geos-3.5 and 
> proj-4.8, but the package name doesn't match (also the version).
>

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 21 Feb 2018 17:46:09 +0000

Hi,

> Thanks for fixing this issue!

Apologies for the delay, it took more time that I was expecting. I want to
thank John Harvey for spec file fixes.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR