Subject: Oracle Enterprise Linux 6.9 - pgadmin4 not in Repo

From: Markus Bräunig <[email-masked]>
Date: Sun, 1 Jul 2018 13:39:20 +0000

Hi all,

I tried to fill out a bug in redmine (https://redmine.postgresql.org/issues/3416), but it is still assigned to me despite I answered the open question.
So #postgresql lead me to this list.

Problem is, that the recommended package pgadmin4 (without -v1/v2) is not in the Repository for RHEL6/OL6.
https://yum.postgresql.org/9.6/redhat/rhel-6-x86_64/

The packages v1/v2 are kind of broken (dependency errors like "Package pgadmin4-python-crypto is obsoleted by pgadmin4-python3-crypto, but obsoleting package does not provide for requirements“

So could anybody built a working package for this repo?
Right now it could not be installed.

Regards
Markus

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 02 Jul 2018 10:42:40 +0100

Hi,

On Sun, 2018-07-01 at 13:39 +0000, Markus Bräunig wrote:
> 
> I tried to fill out a bug in redmine (https://redmine.postgresql.org/issues/3
> 416), but it is still assigned to me despite I answered the open question.
> The packages v1/v2 are kind of broken (dependency errors like "Package
> pgadmin4-python-crypto is obsoleted by pgadmin4-python3-crypto, but
> obsoleting package does not provide for requirements“
> 

My bad, forgot to update the ticket. Apologies.

We don't support pgAdmin4 on RHEL/OL/CentOS/SL/Whatever 6, due to build issues.
However, we are working on a new packaging system for pgAdmin4, and the next
version will probably be available for RHEL 6 as well.

That said, you can use the Pyhton Wheel until then:

https://www.pgadmin.org/download/pgadmin-4-python-wheel/

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR