Subject: Oracle Linux 6 PostgreSQL 11 Support?

From: Jason Petersen <[email-masked]>
Date: Tue, 23 Oct 2018 13:03:33 -0600

My scripts to build new builderboxen are failing for Oracle Linux 6… it appears that the pgdg rpm for Oracle Linux 6 is either not present or misnamed (i.e. the rpm to add the repo, not the one for any particular package).

Oracle Linux 7, PG 11 (correct)

lftp -e 'cls -1; bye' https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-7-x86_64/ | egrep '^pgdg-oraclelinux11-11.*rpm'
cd ok, cwd=/pub/repos/yum/11/redhat/rhel-7-x86_64
pgdg-oraclelinux11-11-2.noarch.rpm

Oracle Linux 6, PG 10 (correct)

lftp -e 'cls -1; bye' https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-6-x86_64/ | egrep '^pgdg-oraclelinux10-10.*rpm'

cd ok, cwd=/pub/repos/yum/10/redhat/rhel-6-x86_64
pgdg-oraclelinux10-10-1.noarch.rpm
pgdg-oraclelinux10-10-2.noarch.rpm

Oracle Linux 6, PG 11 (no matches)

lftp -e 'cls -1; bye' https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-6-x86_64/ | egrep '^pgdg-oraclelinux'
cd ok, cwd=/pub/repos/yum/11/redhat/rhel-6-x86_64

Can this be fixed/addressed? It appears there are Oracle Linux 6 packages, just no pgdg rpm, for whatever reason.

--
Jason Petersen
Software Engineer | Citus Data
303.736.9255
[email-masked]

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 30 Oct 2018 11:17:10 +0000

Hi,

On Tue, 2018-10-23 at 13:03 -0600, Jason Petersen wrote:
> lftp -e 'cls -1; bye' 
> https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-6-x86_64/4/ |
> egrep '^pgdg-oraclelinux'

Sorry for the delay. Fixed, and pushed to staging repo. They will appear in a
few minutes.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR