Subject: Adding YUM packages to repository

From: Bruno Lavoie <[email-masked]>
Date: Thu, 15 Oct 2020 10:38:46 -0400

Hi packagers,

What does it take to have an extension / project to be packaged and
deployed across official repos?

For example, if we want to have this project easily installable without
manual compiling fuss:
https://github.com/niquola/jsonknife

Or, if we want to build our custom package locally, any recipe to build an
RPM from this?

So many thanks
Your project is so useful, loved !

Bruno

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 15 Oct 2020 19:27:46 +0300

Hi,

Ask them to create a tarball first. They don't have any releases 

Regards, Devrim

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: "Regina Obe" <[email-masked]>
Date: Thu, 15 Oct 2020 13:00:23 -0400

Yah having a tagged release is a good first step.  Packagers don’t like distributing extensions without a tagged release as it’s too hard to troubleshoot if things go wrong.

It also gives a sense of commitment if the project is willing to do releases.  

Last thing a packager wants is for people to rely on functionality in an extension and then the project stops working on newer releases of PostgreSQL and doesn’t want to put in the effort to make it work on newer releases.

Thanks,

Regina

From: Devrim Gündüz [mailto:[email-masked]] 
Sent: Thursday, October 15, 2020 12:28 PM
To: [email-masked]; Bruno Lavoie <[email-masked]>
Subject: Re: Adding YUM packages to repository

Hi,

Regards, Devrim

On 15 October 2020 17:38:46 GMT+03:00, Bruno Lavoie <[email-masked] <mailto:[email-masked]> > wrote:

Hi packagers, 

What does it take to have an extension / project to be packaged and deployed across official repos?

For example, if we want to have this project easily installable without manual compiling fuss: 

Or, if we want to build our custom package locally, any recipe to build an RPM from this?

So many thanks

Bruno