Subject: pgbadger on Centos 8

From: pinker <[email-masked]>
Date: Fri, 21 Aug 2020 02:01:15 -0700 (MST)

Hi Devrim,
any chance to fix it?

[root@test pg_log]# dnf install pgbadger
Last metadata expiration check: 0:40:45 ago on Fri 21 Aug 2020 08:18:29 AM
UTC.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides perl-Text-CSV_XS needed by pgbadger-11.3-1.rhel8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
use not only best candidate packages)
[root@test pg_log]# dnf search pgbadger
Last metadata expiration check: 0:41:12 ago on Fri 21 Aug 2020 08:18:29 AM
UTC.
==================================================== Name Exactly Matched:
pgbadger ====================================================
pgbadger.noarch : A fast PostgreSQL log analyzer
[root@test pg_log]# cat /etc/redhat-release 
CentOS Linux release 8.2.2004 (Core)

--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pkg-yum-f6042034.html

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 24 Aug 2020 09:28:11 +0100

Hi,

> any chance to fix it?

You need epel-release for that package:

dnf -y install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm

Regards, 
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR