Subject: Download question

From: "WHITMORE, MARK J GS-12 USAF AFMC 517 SMXS/MXDEC" <[email-masked]>
Date: Tue, 29 Sep 2015 14:57:16 +0000

I support a network of Red Hat machines that is not connected to the internet, so can't touch your
yum repo.   Previously we used EnterpriseDB's version of PostgreSQL but now that they have gone
to Posgres Advanced Server instead of just PostgreSQL my customers requested that I just get
PostgreSQL 9.4 from you instead.     Since I can't access the repository to simply do "yum install"

I need to know which packages to download to install PostgreSQL 9.4 on RHEL 7.0 Workstation.

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Jeff Frost <[email-masked]>
Date: Tue, 29 Sep 2015 10:22:55 -0700

Mark,

I just launched a fresh centos7 vagrant, configured the yum repo and installed postgresql94 postgresql94-contrib postgresql94-libs and postgresql94-server.

Here’s what all yum decided to download:

=============================================================================================================================================================================================================================================
 Package                                                          Arch                                               Version                                                        Repository                                          Size
=============================================================================================================================================================================================================================================
Installing:
 postgresql94                                                     x86_64                                             9.4.4-1PGDG.rhel6                                              pgdg94                                             1.0 M
 postgresql94-contrib                                             x86_64                                             9.4.4-1PGDG.rhel6                                              pgdg94                                             529 k
 postgresql94-libs                                                x86_64                                             9.4.4-1PGDG.rhel6                                              pgdg94                                             193 k
 postgresql94-server                                              x86_64                                             9.4.4-1PGDG.rhel6                                              pgdg94                                             4.3 M
Installing for dependencies:
 libxslt                                                          x86_64                                             1.1.26-2.el6_3.1                                               base                                               452 k
Updating for dependencies:
 openssl                                                          x86_64                                             1.0.1e-42.el6                                                  base                                               1.5 M
 openssl-devel                                                    x86_64                                             1.0.1e-42.el6                                                  base                                               1.2 M

Let me know if you want any of the other packages and I can test that as well.

> On Sep 29, 2015, at 7:57 AM, WHITMORE, MARK J GS-12 USAF AFMC 517 SMXS/MXDEC <[email-masked]> wrote:
> 

---
Jeff Frost <[email-masked]>
CTO, PostgreSQL Experts, Inc.
Phone: 1-888-PG-EXPRT x506
FAX: 415-762-5122
http://www.pgexperts.com/

---

From: Martín Marqués <[email-masked]>
Date: Sun, 4 Oct 2015 19:44:45 -0300

> Here’s what all yum decided to download:

If you were installing on a centos7 system, why did you get rhel6 packages?

I get this on my centos local VM:

[root@rhel7 ~]# yum install postgresql94-libs postgresql94-contrib
postgresql94-server
Loaded plugins: fastestmirror, langpacks
Determining fastest mirrors
 * base: mirrors.dcarsat.com.ar
 * extras: mirrors.dcarsat.com.ar
 * updates: mirrors.dcarsat.com.ar
Resolving Dependencies
--> Running transaction check
---> Package postgresql94-contrib.x86_64 0:9.4.4-1PGDG.rhel7 will be
installed
--> Processing Dependency: postgresql94(x86-64) = 9.4.4-1PGDG.rhel7 for
package: postgresql94-contrib-9.4.4-1PGDG.rhel7.x86_64
---> Package postgresql94-libs.x86_64 0:9.4.4-1PGDG.rhel7 will be installed
---> Package postgresql94-server.x86_64 0:9.4.4-1PGDG.rhel7 will be
installed
--> Running transaction check
---> Package postgresql94.x86_64 0:9.4.4-1PGDG.rhel7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================
 Package                   Arch        Version
Repository   Size
=================================================================================
Installing:
 postgresql94-contrib      x86_64      9.4.4-1PGDG.rhel7       pgdg94
   609 k
 postgresql94-libs         x86_64      9.4.4-1PGDG.rhel7       pgdg94
   208 k
 postgresql94-server       x86_64      9.4.4-1PGDG.rhel7       pgdg94
   3.9 M
Installing for dependencies:
 postgresql94              x86_64      9.4.4-1PGDG.rhel7       pgdg94
   1.0 M

Transaction Summary
=================================================================================
Install  3 Packages (+1 Dependent package)

BTW Mark, you can use yumdownloader with the same list of packages to
download all the rpms on a machine with access to the internet and then
pass the rpms over to the final server (I imagine that's the problem you
are trying to circumvent).

Regards,

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services