Subject: Disabling of postgresql module

From: "Duggins, Kyle" <[email-masked]>
Date: Fri, 12 Apr 2024 15:24:15 +0000

I am curious as to why in rhel 8 that postgresql module needs to be disabled. As rhel does not support postgresql16 and that the competing repos came from when running a yum update, but by disabling postgresql module it eliminated the competing repo. Why would this be if there is not postgresql16 module on rhel 8?

-----
This email and any attached files are confidential and intended solely for the intended recipient(s). If you are not the named recipient(s), you should not read, distribute, copy or alter this message. Any views or opinions expressed herein are those of the author and do not represent those of the Coeur d'Alene Tribe. Warning: Although precautions have been taken to ensure no viruses are present, the Coeur d'Alene Tribe cannot accept responsibility for any loss or damage that may occur from the use of this email or attachments.

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 12 Apr 2024 18:57:05 +0200

On Fri, 2024-04-12 at 15:24 +0000, Duggins, Kyle wrote:
> I am curious as to why in rhel 8 that postgresql module needs to be disabled.
> As rhel does not support postgresql16 and that the competing repos came from
> when running a yum update, but by disabling postgresql module it eliminated
> the competing repo. Why would this be if there is not postgresql16 module on rhel 8?

That is for safety reasons.  Perhaps it cannot happen with v16, but in general
it is a bad idea to install PGDG packages and Redhat packages side by side.
They are configured differently, and if you mix, you get interesting and
hard-to-debug problems.

Yours,
Laurenz Albe

---

From: Christoph Berg <[email-masked]>
Date: Mon, 15 Apr 2024 22:42:12 +0200

Re: Duggins, Kyle
> I am curious as to why in rhel 8 that postgresql module needs to be disabled. As rhel does not support postgresql16 and that the competing repos came from when running a yum update, but by disablin…

If you don't disable the postgresql-module, none of the server
packages from yum.postgresql.org are visible on RHEL8 (rocky 8 actually):

$ sudo yum search postgresql server
======================================================== Name & Summary Matched: server, postgresql =========================================================
postgresql-server.x86_64 : The programs needed to create and run a PostgreSQL server
postgresql-server-devel.x86_64 : PostgreSQL development header files and libraries

$ sudo dnf module disable postgresql

$ sudo yum search postgresql server
======================================================== Name & Summary Matched: server, postgresql =========================================================
postgresql12-server.x86_64 : The programs needed to create and run a PostgreSQL server
postgresql13-server.x86_64 : The programs needed to create and run a PostgreSQL server
postgresql14-server.x86_64 : The programs needed to create and run a PostgreSQL server
postgresql15-server.x86_64 : The programs needed to create and run a PostgreSQL server
postgresql16-server.x86_64 : The programs needed to create and run a PostgreSQL server

Christoph