Subject: gdal32-libs dependency on libpoppler.so in CentOS 8 is broken

From: Paul De Audney <[email-masked]>
Date: Fri, 12 Mar 2021 12:00:58 +1100

Hi List,

It looks like libpoppler.so from the poppler package in CentOS 8 (probably
RHEL 8 too) has been updated and the dependency on it from gdal32-libs is
broken. The version in the package is libpoppler.so.104.
As such PostGIS is not installable at this time using the repository (as
far as I can tell).

> yum install gdal32-libs

 Problem: cannot install the best candidate for the job
  - nothing provides libpoppler.so.78()(64bit) needed by
gdal32-libs-3.2.1-1.rhel8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
use not only best candidate packages)

> repoquery -i gdal32-libs

Name         : gdal32-libs
Version      : 3.2.0
Release      : 3.rhel8
Architecture : x86_64
Size         : 8.3 M
Source       : gdal32-3.2.0-3.rhel8.src.rpm
Repository   : pgdg-common
Summary      : GDAL file format library
URL          : http://www.gdal.org
License      : MIT
Description  : This package contains the GDAL file format library.

Name         : gdal32-libs
Version      : 3.2.1
Release      : 1.rhel8
Architecture : x86_64
Size         : 8.3 M
Source       : gdal32-3.2.1-1.rhel8.src.rpm
Repository   : pgdg-common
Summary      : GDAL file format library
URL          : http://www.gdal.org
License      : MIT
Description  : This package contains the GDAL file format library.

> rpm -qi poppler

Name        : poppler
Version     : 20.11.0
Release     : 2.el8
Architecture: x86_64
Install Date: Thu 11 Mar 2021 14:54:19 UTC
Group       : Unspecified
Size        : 3894353
License     : (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
Signature   : RSA/SHA256, Tue 15 Dec 2020 23:58:08 UTC, Key ID
05b555b38483c65d
Source RPM  : poppler-20.11.0-2.el8.src.rpm
Build Date  : Fri 11 Dec 2020 17:51:58 UTC
Build Host  : x86-02.mbox.centos.org
Relocations : (not relocatable)
Packager    : CentOS Buildsys <[email-masked]>
Vendor      : CentOS
URL         : http://poppler.freedesktop.org/
Summary     : PDF rendering library
Description :
poppler is a PDF rendering library.

rpm -ql poppler

/usr/lib/.build-id
/usr/lib/.build-id/50
/usr/lib/.build-id/50/adf5cdb57db98e12b2db0a0c77c90df41790f0
/usr/lib64/libpoppler.so.104
/usr/lib64/libpoppler.so.104.0.0
/usr/share/doc/poppler
/usr/share/doc/poppler/README.md
/usr/share/licenses/poppler
/usr/share/licenses/poppler/COPYING
/usr/lib/.build-id
/usr/lib/.build-id/e9
/usr/lib/.build-id/e9/dd205684d391dea94a61e73750906098210b90
/usr/lib/libpoppler.so.104
/usr/lib/libpoppler.so.104.0.0
/usr/share/doc/poppler
/usr/share/doc/poppler/README.md
/usr/share/licenses/poppler
/usr/share/licenses/poppler/COPYING

Regards,

Paul De Audney

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 15 Mar 2021 17:45:54 +0000

Hi,

Thanks for the report. Looking at it now.

Regards, Devrim

-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 15 Mar 2021 23:12:56 +0000

Hi,

> Release     : 2.el8

We don't support CentOS 8 Stream *yet*. It's in the radar -- probably
I'll start building packages in Q2.

Regards,