Subject: [Rockey 9x] Postgis Installation failed due to missing dependencies

From: Zaid Shabbir <[email-masked]>
Date: Mon, 19 Aug 2024 19:10:49 +0500

Hello,

I am attempting to install PostGIS 3.4 for PostgreSQL 16 from the official
PostgreSQL repository. The installation did not proceed due to missing
dependencies.

dnf install postgis34_16

Last metadata expiration check: 0:00:18 ago on Mon Aug 19 14:03:46 2024.

Error:

 Problem: cannot install the best candidate for the job

  - nothing provides hdf5 needed by postgis34_16-3.4.2-3PGDG.rhel9.x86_64
from pgdg16

  - nothing provides xerces-c needed by
postgis34_16-3.4.2-3PGDG.rhel9.x86_64 from pgdg16

I don't see depend packages under the repository
https://download.postgresql.org/pub/repos/yum/16/redhat/rhel-9-x86_64/

Regards,

Zaid

---

From: "Regina Obe" <[email-masked]>
Date: Mon, 19 Aug 2024 10:25:59 -0400

Those don’t come from yum.postgresql.org

You enable epel repo or crb as discussed here:

https://postgis.net/documentation/getting_started/install_red_hat/

From: Zaid Shabbir <[email-masked]> 
Sent: Monday, August 19, 2024 10:11 AM
To: pgsql-pkg-yum <[email-masked]>
Subject: [Rockey 9x] Postgis Installation failed due to missing dependencies

Hello,

I am attempting to install PostGIS 3.4 for PostgreSQL 16 from the official PostgreSQL repository. The installation did not proceed due to missing dependencies.

dnf install postgis34_16

Error: 

  - nothing provides hdf5 needed by postgis34_16-3.4.2-3PGDG.rhel9.x86_64 from pgdg16

  - nothing provides xerces-c needed by postgis34_16-3.4.2-3PGDG.rhel9.x86_64 from pgdg16

 

Regards,

Zaid

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 20 Aug 2024 16:18:18 +0300

Hi,

> PostgreSQL repository. The installation did not proceed due to missing

For the archives: https://yum.postgresql.org/howto/ has information
about installing GIS stack.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR