Subject: Unable to install pgadmin4 on Alma Linux 9

From: "Christelle K." <[email-masked]>
Date: Fri, 12 Jan 2024 16:38:17 +0200

Hi,

I hope this email finds you well. I have been trying to install pgadmin4 on
Alma linux 9 but I have so many issues.
I have *run dnf clean all *and* rm -r /var/chache/dnf* but still I am
getting "error during download of metadata". these are the error that I am
facing

 This issue has been going on for days now. It seems that those links are
not working, Can you help with this issue?
Kind regards,
*Christelle*

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 12 Jan 2024 16:29:59 +0100

On Fri, 2024-01-12 at 16:38 +0200, Christelle K. wrote:
> I hope this email finds you well. I have been trying to install pgadmin4 on Alma linux 9 but I have so many issues.
> I have run dnf clean all and rm -r /var/chache/dnf but still I am getting "error during download of metadata". these are the error that I am facing

Try installing the latest repository RPM:

  sudo dnf install -y https://download.postgresql.org/pub/repos/yum/reporpms/EL-9-x86_64/pgdg-redhat-repo-latest.noarch.rpm

If that creates an /etc/yum.repos.d/pgdg-redhat-all.repo.rpmnew, replace the old repository:

  sudo mv /etc/yum.repos.d/pgdg-redhat-all.repo.rpmnew /etc/yum.repos.d/pgdg-redhat-all.repo

Yours,
Laurenz Albe