Subject: Clarification on Naming convention of the new recent packages #162

From: "M, Anbazhagan" <[email-masked]>
Date: Thu, 5 Mar 2026 04:13:43 +0000

We noticed that all newly uploaded packages under the RHEL 8 repos like rhel-8.8/rhel-8.9/rhel-8.10 etc. contain 8.10 in the package name, regardless of the actual minor version of that repo.

Could you confirm if this is intentional or if the package should reflect specific RHEL 8 minor version in their names?

Example:
https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-8.9-x86_64/ contains rpm named as [postgresql15-15.17-1PGDG.rhel8.10.x86_64.rpm]

(https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-8.9-x86_64/postgresql15-15.17-1PGDG.rhel8.10.x86_64.rpm)

Anbazhagan M
Staff Engineer, Technical Operations
Instaclustr by Netapp

NetApp
+91-8056005329 Mobile Phone
[email-masked]<mailto:[email-masked]>

[NetApp logo]<https://www.netapp.com/>

[A white face with black eyes  Description automatically generated]<https://netappdiscord.com/>[A black background with a black square  Description automatically generated with medium confidence]<https://www.facebook.com/NetApp>[NetApp on Instagram]<https://www.instagram.com/netapp/>[NetApp on LinkedIn]<https://www.linkedin.com/company/netapp/>[NetApp on YouTube]<https://www.youtube.com/netapp>[NetApp on X]<https://twitter.com/NetApp>

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 09 Mar 2026 14:07:01 +0000

Hi,

Aready replied you here:

https://github.com/pgdg-packaging/pgdg-rpms/issues/162

On Thu, 2026-03-05 at 04:13 +0000, M, Anbazhagan wrote:
> We noticed that all newly uploaded packages under the RHEL 8 repos
> like rhel-8.8/rhel-8.9/rhel-8.10 etc. contain 8.10 in the package
> name, regardless of the actual minor version of that repo.
> 
> Could you confirm if this is intentional or if the package should
> reflect specific RHEL 8 minor version in their names?
> 
> Example:
> https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-8.9-x86_64/
>  contains rpm named as [postgresql15-15.17-1PGDG.rhel8.10.x86_64.rpm]
> 
> (
> https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-8.9-x86_64
> /postgresql15-15.17-1PGDG.rhel8.10.x86_64.rpm)
> 
> 
> Anbazhagan M
> [A white face with black eyes  Description automatically
> generated]<https://netappdiscord.com/>[A black background with a black
> square  Description automatically generated with medium
> confidence]<https://www.facebook.com/NetApp>[NetApp on
> Instagram]<https://www.instagram.com/netapp/>[NetApp on
> LinkedIn]<https://www.linkedin.com/company/netapp/>[NetApp on
> YouTube]<https://www.youtube.com/netapp>[NetApp on
> X]<https://twitter.com/NetApp>

-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
BlueSky: @devrim.gunduz.org , @gunduz.org

---

From: "M, Anbazhagan" <[email-masked]>
Date: Mon, 9 Mar 2026 14:08:23 +0000

Hi Devrim,

I was clarified with your response in GitHub issues. This can be closed.

________________________________
From: Devrim Gündüz <[email-masked]>
Sent: Monday, March 9, 2026 7:37:15 pm
To: M, Anbazhagan <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Clarification on Naming convention of the new recent packages #162

Hi,

Aready replied you here:

---

From: Eduar Flow <[email-masked]>
Date: Mon, 9 Mar 2026 10:44:14 -0600

Hi Anbazhagan,

This behavior is expected.

The PGDG RPMs for RHEL 8 are typically built against the most recent minor
release available (currently 8.10). Because Red Hat Enterprise Linux
maintains ABI compatibility across RHEL 8 minor versions, packages built on
8.10 remain compatible with earlier minor releases such as 8.9, 8.8, etc.

For that reason, the package naming may include the ".rhel8.10" suffix even
when the RPM is located in repositories corresponding to earlier minor
versions like "rhel-8.9-x86_64".

In short, the suffix reflects the build environment rather than a strict
requirement for that exact minor release.

Best regards

Yekma666

El lun, 9 de mar de 2026, 08:36, M, Anbazhagan <[email-masked]>
escribió:

> ------------------------------
> *From:* Devrim Gündüz <[email-masked]>
> *Sent:* Monday, March 9, 2026 7:37:15 pm
> *To:* M, Anbazhagan <[email-masked]>;
> [email-masked] <[email-masked]>
> *Subject:* Re: Clarification on Naming convention of the new recent
> packages #162
>
>
> Hi,
>
> Aready replied you here:
>

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 10 Mar 2026 11:38:26 +0300

Hi,

On Mon, 2026-03-09 at 10:44 -0600, Eduar Flow wrote:
> The PGDG RPMs for RHEL 8 are typically built against the most recent
> minor release available (currently 8.10). Because Red Hat Enterprise
> Linux maintains ABI compatibility across RHEL 8 minor versions,
> packages built on 8.10 remain compatible with earlier minor releases
> such as 8.9, 8.8, etc.
> 
> For that reason, the package naming may include the ".rhel8.10" suffix
> even when the RPM is located in repositories corresponding to earlier
> minor versions like "rhel-8.9-x86_64".
> 
> In short, the suffix reflects the build environment rather than a
> strict requirement for that exact minor release.

If this is an AI response, it is not funny and it is incorrect. If this
is not AI response, it is incorrect.

Per:

https://access.redhat.com/articles/rhel8-abi-compatibility
https://access.redhat.com/articles/rhel9-abi-compatibility
https://access.redhat.com/articles/rhel10-abi-compatibility

"During the life cycle of a major release, Red Hat makes commercially
reasonable efforts to maintain the binary compatibility of the runtime
environment across all minor releases and errata advisories. If
necessary, Red Hat may make exceptions to this compatibility goal for
critical impact security or other significant issues."

Regards,