Subject: Problem with postgis 3.1 on RHEL9

From: "Lorenz, Christopher" <[email-masked]>
Date: Mon, 2 Dec 2024 10:15:58 +0000

Hello,

while Updating RHEL9 we have problem with the dependencies. Postgis 3.1 is installed with dependency on gdal38-libs, but the current gdal38-libs requires libSFCGAL.so.2, but postgis31_13 itself  libSFCGAL.so.1 as I understand. Can anyone reproduce the problem? Is there a need to compile postgis 3.1 against libSFCGAL.so.2?

Result while try to update our system:

 Problem 1: package postgis31_13-3.1.11-3PGDG.rhel9.x86_64 from @System requires libSFCGAL.so.1()(64bit), but none of the providers can be installed
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.5.1-2PGDG.rhel9.x86_64 from @System
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.4.1-11.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.5.1-2PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64
  - cannot install both SFCGAL-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-1.5.0-1.el9.x86_64 from ZIT-BB_Extra_Packages_for_Enterprise_Linux_EPEL_-_RHEL_9_x86_64
  - cannot install the best update candidate for package postgis31_13-3.1.11-3PGDG.rhel9.x86_64
  - cannot install the best update candidate for package SFCGAL-libs-1.5.1-2PGDG.rhel9.x86_64
  - cannot install the best update candidate for package SFCGAL-1.5.1-2PGDG.rhel9.x86_64

 Problem 2: Problem mit installiertem Paket postgis31_13-3.1.11-3PGDG.rhel9.x86_64
  - package postgis31_13-3.1.11-3PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL13_-_RHEL_9_x86_64 requires libSFCGAL.so.1()(64bit), but none of the providers can be installed
  - package postgis31_13-3.1.11-3PGDG.rhel9.x86_64 from @System requires libSFCGAL.so.1()(64bit), but none of the providers can be installed
  - cannot install both SFCGAL-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-1.5.0-1.el9.x86_64 from ZIT-BB_Extra_Packages_for_Enterprise_Linux_EPEL_-_RHEL_9_x86_64
  - Problem mit installiertem Paket SFCGAL-1.5.1-2PGDG.rhel9.x86_64
  - package SFCGAL-1.5.1-2PGDG.rhel9.x86_64 from @System requires SFCGAL-libs(x86-64) = 1.5.1-2PGDG.rhel9, but none of the providers can be installed
  - package SFCGAL-1.5.1-2PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 requires SFCGAL-libs(x86-64) = 1.5.1-2PGDG.rhel9, but none of the providers can be installed
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.5.1-2PGDG.rhel9.x86_64 from @System
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.4.1-11.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64
  - cannot install both SFCGAL-libs-2.0.0-1PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 and SFCGAL-libs-1.5.1-2PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64
  - package gdal38-libs-3.8.5-5PGDG.rhel9.x86_64 from ZIT-BB_PostgreSQL_PostgreSQL-common_-_RHEL_9_x86_64 requires libSFCGAL.so.2()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package gdal38-libs-3.8.5-3PGDG.rhel9.x86_64
(Versuchen Sie '--allowerasing' zur Befehlszeile hinzuzufügen, um Pakete mit Konflikten zu ersetzen or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

May there are more affected combination, I also have trouble with postgis 3.2 and PostgreSQL 15 on RHEL9.

Best Regards,

Christopher Lorenz

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 09 Dec 2024 01:33:10 +0300

Hi,

On Mon, 2024-12-02 at 10:15 +0000, Lorenz, Christopher wrote:
> 
> 
> while Updating RHEL9 we have problem with the dependencies. Postgis
> 3.1 is installed with dependency on gdal38-libs, but the current
> gdal38-libs requires libSFCGAL.so.2, but postgis31_13 itself 
> libSFCGAL.so.1 as I understand. Can anyone reproduce the problem? Is
> there a need to compile postgis 3.1 against libSFCGAL.so.2?

<snip>

> postgis 3.2 and PostgreSQL 15 on RHEL9.

<snip>

Sorry for the inconvenience and late reply. Pushed these packages to
repos.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR