Subject: Fedora 22

From: jared <[email-masked]>
Date: Tue, 26 May 2015 18:02:04 +0000

Hello,
I am wondering what the usual delay is on packages for a newly released
Fedora?

http://yum.postgresql.org/9.4/fedora/

For instance - for fedora 22 packages would that be:
fedora 22 release date + 1 week?

(granted the Fedora 22 release occurred today, so I am just looking for in
general I should look for it by...) guidance.

And thanks for the hard work on packaging and other work you do.

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Thu, 28 May 2015 01:24:24 +0300

Hi,

On Tue, 2015-05-26 at 18:02 +0000, jared wrote:
> I am wondering what the usual delay is on packages for a newly
> released Fedora?

> http://yum.postgresql.org/9.4/fedora/

The problem is I missed Fedora 22 release date :( Just working on the
new build server. I believe I can push the new packages starting
tomorrow.

Regards,

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Yogesh Sharma <[email-masked]>
Date: Wed, 27 May 2015 21:18:09 -0700

> new build server. I believe I can push the new packages starting

Hello Devrim,

Possible to build postgresql 9.2 packages also for Fedora 22 ?

--
Thanks
Yogesh

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Thu, 28 May 2015 09:12:07 +0300

Hi,

> Possible to build postgresql 9.2 packages also for Fedora 22 ?

Fedora 21 used PostgreSQL 9.3, so I am not inclined to build 9.2 for
Fedora 22, unless there is a strong demand for that.

Regards,

---

From: jared <[email-masked]>
Date: Tue, 07 Jul 2015 18:32:53 +0000

Hello, I noticed the packages have landed for fedora 22.

When I try to install them it says:

Error: Package <package name here> is not signed

Do you know if that is an issue with the repository having unsigned
packages - or is that a local issue where my dnf has not properly imported
a key?

---

From: Yogesh Sharma <[email-masked]>
Date: Tue, 07 Jul 2015 11:36:53 -0700

Due to an unsolved issue current packages are pushed without gpg signing.

you can pass --nogpg option to dnf or yum command.

On 07/07/2015 11:32 AM, jared wrote:
> packages - or is that a local issue where my dnf has not properly
> imported a key?
>
>
>
> On Wed, May 27, 2015 at 6:24 PM Devrim GÜNDÜZ <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>

-- 
Kind Regards,
Yogesh Sharma

credativ LLC
270 E Douglas Ave, El Cajon, CA 92020
Office: +1 619 270 8787
Direct: +1 619 639 4543
=======================================
USA:         http://www.credativ.us
---------------------------------------
Global:       http://www.credativ.com
Germany:     http://www.credativ.de
UK:          http://www.credativ.co.uk
Canada:      http://www.credativ.ca
India:       http://www.credativ.in
Netherlands: http://www.credativ.nl
=======================================

---

From: jared <[email-masked]>
Date: Tue, 07 Jul 2015 18:37:31 +0000

thanks again.

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Thu, 09 Jul 2015 14:47:08 +0300

Hi,

> packages - or is that a local issue where my dnf has not properly 

Update on this: I just pushed updated packages that are all signed.
Fixed the issue with the rpm signing on Fedora 22 boxes.

Regards,

---

From: Martín Marqués <[email-masked]>
Date: Mon, 17 Aug 2015 15:40:22 -0300

> Fixed the issue with the rpm signing on Fedora 22 boxes.

Something is not right. Is it possible that the yum.postgresql.org site
is outdated or that there's missing information?

http://yum.postgresql.org/repopackages.php

Only packages for F22 are the PG 9.5 ones.

Also, running fedup errors out with this:

Downloading failed: El paquete pgbouncer-1.5.5-2.f22.x86_64.rpm no está
firmado

(sorry that it's in Spanish. It says the package is not signed)

Trying to install
http://yum.postgresql.org/9.5/fedora/fedora-22-x86_64/pgdg-fedora95-9.5-1.noarch.rpm
I get that that package is not signed as well.

Is it possible I'm looking in the wrong place?

Regards,

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 26 Aug 2015 13:17:54 +0300

Hi,

On Mon, 2015-08-17 at 15:40 -0300, Martín Marqués wrote:

> Something is not right. Is it possible that the yum.postgresql.org 
> site is outdated or that there's missing information?
> 

Fixed.

> Is it possible I'm looking in the wrong place?

I think the link is outdated as well. Just updated the URL above so
that it points to the correct repo package (which is signed)

Regards,

---

From: Martín Marqués <[email-masked]>
Date: Fri, 25 Sep 2015 20:23:02 -0300

> that it points to the correct repo package (which is signed)

This wasn't solved and I'm getting the same error, but with the
postgresql package now:

Downloading failed: Package
postgresql93-server-9.3.9-1PGDG.f22.x86_64.rpm is not signed

Regards,

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Mon, 12 Oct 2015 22:36:19 +0300

Hi,

> postgresql93-server-9.3.9-1PGDG.f22.x86_64.rpm is not signed

Sorry, but I could not duplicate this on my desktop machine that I
upgraded to Fedora 22 last week :(

Did you run 

dnf clean all 

Regards,

---

From: Martín Marqués <[email-masked]>
Date: Mon, 12 Oct 2015 17:34:35 -0300

This isn't working:

[root@endor ~]# dnf clean all
Cleaning repos: pgdg93 pgdg94 google-talkplugin fedora
icinga-stable-release rpmfusion-free-updates fedora-chromium
adobe-linux-x86_64 rpmfusion-free
              : rpmfusion-nonfree-updates
postgresql-bdr94-2ndquadrant-fedora updates google-chrome
rpmfusion-nonfree
Cleaning up Everything
[root@endor ~]# fedup-cli --network 22
setting up repos...
getting boot images...
.treeinfo.signed

   | 2.0 kB  00:00:00
setting up update...

[....]

Downloading failed: Package check_postgres-2.22.0-1.f22.noarch.rpm is not signed