Subject: RFC: pgbouncer 1.6, PL/Lua, luapgsql

From: David Fetter <[email-masked]>
Date: Thu, 27 Aug 2015 14:45:12 -0700

Folks,

I'd love to be able to update pgbouncer to 1.6, as it's got a lot of
handy new features, and has squashed some pretty annoying misfeatures.

Also, it'd be great to add the following.

- PL/Lua https://github.com/pllua/pllua
- luapgsql https://github.com/mbalmer/luapgsql

So now that I've asked for stuff, I'd also like to be able to help.

How can I help?

Is there some kind of buildfarm or similar to test all the distros?

Cheers,
David.
-- 
David Fetter <[email-masked]> http://fetter.org/
Phone: +1 415 235 3778  AIM: dfetter666  Yahoo!: dfetter
Skype: davidfetter      XMPP: [email-masked]

Remember to vote!
Consider donating to Postgres: http://www.postgresql.org/about/donate

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Andomar <[email-masked]>
Date: Tue, 8 Sep 2015 17:12:19 +0200

> handy new features, and has squashed some pretty annoying misfeatures.
It looks like pgbouncer 1.6 is live now, we get the 1.6.1-1.rhel6 
package from: http://yum.postgresql.org/9.4/redhat/

Cheers,
Andomar

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 09 Sep 2015 00:00:14 +0300

Hi David,

> handy new features, and has squashed some pretty annoying

Thanks for the offer. I pushed the RPMs yesterday. Still, a patch is
always welcome for the next releases!

> So now that I've asked for stuff, I'd also like to be able to help.

Awesome! I can't see a release for PL/Lua though, you may want 	
to ping the developers to roll out a release first.

> How can I help?

Please submit the spec file to us. We'll review and commit it.

> Is there some kind of buildfarm or similar to test all the distros?

We have the regular RPM buildfarm. Before pushing out changes, I always
test the spec files on my F-22 (or whatever the latest will be) box for
any issues.

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR