Subject: pgbouncer systemd does not work on CentOS 7

From: Peter Eisentraut <[email-masked]>
Date: Wed, 06 May 2015 15:52:37 -0400

After installing pgbouncer-1.5.5-1.rhel7.x86_64.rpm on CentOS 7.0, it
does not remain running.  No errors are logged.

I think the systemd configuration is faulty.  It currently reads

[Service]
Type=forked

...

ExecStart=/usr/bin/pgbouncer -d -v ${BOUNCERCONF}

If I change that to

[Service]
Type=simple

...

ExecStart=/usr/bin/pgbouncer -v ${BOUNCERCONF}

it works

Alternatively, the first version can be made to work by adding
RemainAfterExit=yes.

But clearly, the second version is more in line with the systemd philosophy.

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 13 May 2015 00:26:54 +0300

Hi Peter,

> But clearly, the second version is more in line with the systemd philosophy.

Thanks for the report. I picked up second way, and committed to git.

Regards,

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 15 May 2015 16:04:39 -0400

> Thanks for the report. I picked up second way, and committed to git.

Why?  Wouldn't the non-forking approach be more in line with what
systemd expects?

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 22 Sep 2015 14:52:27 -0400

> Why?  Wouldn't the non-forking approach be more in line with what

ping

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Tue, 22 Sep 2015 23:19:03 +0300

Hi Peter,

> > Why?  Wouldn't the non-forking approach be more in line with what

Did you test 1.6.1? That version seems to be working on my RHEL 7 box.

Regards,