Subject: Error install V16.1.4 on Rocky Linux 8.8

From: David PEYRIERES <[email-masked]>
Date: Fri, 24 Nov 2023 15:00:48 +0000 (GMT)

Hi all. 
We got error today during install or upgrade last PostgreSQL release V16.1(-4) on Rocky Linux 8.8. 
(I specify that all was ok with 16.1-2). 

PG16 requires llvm-libs16 while only llvm-15 seems to be available on Rocky 8.8. 

Error: 
Problem: package postgresql16-llvmjit-16.1-4PGDG.rhel8.x86_64 requires libLLVM-16.so()(64bit), but none of the providers can be installed 
- package postgresql16-llvmjit-16.1-4PGDG.rhel8.x86_64 requires libLLVM-16.so(LLVM_16)(64bit), but none of the providers can be installed 
- cannot install the best candidate for the job 
- package llvm-libs-16.0.6-3.el8.x86_64 is filtered out by modular filtering 
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) 

[root@ ~]# cat /etc/redhat-release 
Rocky Linux release 8.8 (Green Obsidian) 

Thanks for you help. 
Regards, David 

-- 

Dav id PEYRIERES 
Direction des Systèmes d'Information - Département Opérations 
Adjoint au responsable de la division B ases de D onnées O pérationnelles 
Expertise/Administration/Support Bases de Données Relationnelles 

Tel : +33 (0)5.61.07.83.36 
[ mailto:[email-masked] | [email-masked] ] 

METEO FRANCE 
[ http://www.meteo.fr/ | www.meteo.fr ] 
42 avenue Gustave Coriolis 
31057 TOULOUSE Cédex

---

From: Matti Linnanvuori <[email-masked]>
Date: Fri, 24 Nov 2023 17:15:33 +0200

Hi!

I guess to install that revision you need a newer release of Rocky Linux that has a newer LLVM.

Best regards

> David PEYRIERES <[email-masked]> kirjoitti 24.11.2023 kello 17.00:
> 
> You don't often get email from [email-masked]. Learn why this is important <https://aka.ms/LearnAboutSenderIdentification>	
> 
> Hi all.
> David PEYRIERES                                                                                                                  
> Adjoint au responsable de la division Bases de Données Opérationnelles 
> Tel :   +33 (0)5.61.07.83.36 <> 
> [email-masked] <mailto:[email-masked]>
> METEO FRANCE 
> www.meteo.fr <https://eur05.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.meteo.fr%2F&data=05%7C01%7Cmatti.linnanvuori%40portalify.com%7C078da4226959480951f808dbecfe2d29%7C9e884580c6374ad6a2733363e46b73e3%7C0%7C0%7C638364348655137516%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=tDgOti2yjha7bW6ic%2B7HeyWViYgb6dBnu1wJmRrX7yY%3D&reserved=0>

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 24 Nov 2023 18:01:30 +0100

Hi,

Please either upgrade to Rocky 8.9 , or read this:

https://yum.postgresql.org/news/rocky-9-8-llvm-repo-is-available/

Regards, Devrim

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.