Subject: pg_repack12

From: Justin Pryzby <[email-masked]>
Date: Fri, 15 Nov 2019 10:01:09 -0600

Shouldn't this be built for RH6?
https://download.postgresql.org/pub/repos/yum/12/redhat/rhel-6-x86_64/

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 17 Nov 2019 00:11:20 +0000

Hi,

> https://download.postgresql.org/pub/repos/yum/12/redhat/rhel-6-x86_64/

oops, fixed. Sorry about that.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Justin Pryzby <[email-masked]>
Date: Sun, 17 Nov 2019 10:39:26 -0600

> > https://download.postgresql.org/pub/repos/yum/12/redhat/rhel-6-x86_64/

I checked what other packages were available for PG12 RH6 vs RH7.
Are these all deliberate?

for a in 11 12; do for b in 6 7; do wget https://yum.postgresql.org/$a/redhat/rhel-$b-x86_64/ -O- |sed 's,</.*,,; s,<[^>]*>, ,g; s/-.*//; s/^ *//; s/11$/12/' |sort -u >$a-$b.dat; done; done
diff 12-6.dat 12-7.dat |grep -Ev '^[,[:xdigit:]]*$|^[<>] (python|proj|postgis|lib|pam|geos|gdal)' # or,
git diff --no-index 12-6.dat 12-7.dat

Available for PG11 RH7 and PG12 RH but not PG12 RH7 (this is the "intersection" of a couple following lists).
pgreplay1*
pg_sample
pg_squeeze1*
pg_track_settings1*
pldebugger1*

These are available for RH6 but not RH7:
pgreplay12
pg_sample
pg_sampletolog12
pg_squeeze12
pg_store_plans12
pg_track_settings12
pitrery
pldebugger12
plpgsql_check_12

These available for RH7 but not RH6:
hdfs_fdw_12
mongo_fdw12
ogr_fdw12
periods_12
pgbackrest
pg_cron_12
pgcryptokey12
pg_dumpbinary
pgloader
pg_monz
pgrouting_12
powa_12

Seem to be missing:
pgtop for PG11, RH6?

Available for PG11 RH7 but not PG12 RH7?
cstore_fdw_12 
mailchimp_fdw
pgadmin4
pg_bulkload12
pg_filedump12
pg_sample
pg_squeeze12
pg_top12
pg_track_settings12
pldebugger12
plproxy12
rum_12
timescaledb_12

Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 19 Nov 2019 10:08:17 +0000

Hi Justin,

> Are these all deliberate?

<snip>

Wow, thanks. Will check and let you know.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 25 Sep 2020 11:56:28 -0500

> git diff --no-index 12-6.dat 12-7.dat

I reran this to compare pg13 vs pg12.

Available for v12 / c7 but not v12 / c8:
-pgagent_12
-repoview

Available for v12 / c7 but not v13 / c7:
-citus_13
-cstore_fdw_12
-extra_window_functions_13
-hll_13
-libpqxx
-multicorn12
-osm2pgrouting_12
-osm_fdw12
-pagila12
-passwordcheck_cracklib13
-pgagent_13
-pgauditlogtofile
-pg_bulkload13
-pg_comparator13
-pg_cron_13
-pgdg
-pg_filedump13
-pglogical_13
-pg_pathman13
-pgpool
-pg_repack12
-pg_squeeze12
-pgtap12
-pg_top12
-pg_wait_sampling_12
-pljava
-postgresql_anonymizer12
-powa_12
-repmgr12
-sqlite_fdw12
-sslutils_12
-tds_fdw12
-topn_12
-wal2mongo12

That appears to be approximately the same as:
c8 v12 vs v13

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 25 Sep 2020 18:20:07 +0100

Hi Justin,

https://twitter.com/DevrimGunduz/status/1308761198742118401?s=19

:)

Cheers, Devrim

On 25 September 2020 17:56:28 BST, Justin Pryzby <[email-masked]> wrote:
>> for a in 11 12; do for b in 6 7; do wget
>https://yum.postgresql.org/$a/redhat/rhel-$b-x86_64/ -O- |sed
>'s,</.*,,; s,<[^>]*>, ,g; s/-.*//; s/^ *//; s/11$/12/' |sort -u
>>$a-$b.dat; done; done
>> diff 12-6.dat 12-7.dat |grep -Ev '^[,[:xdigit:]]*$|^[<>]
>(python|proj|postgis|lib|pam|geos|gdal)' # or,

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 25 Sep 2020 13:38:55 -0500

No problem, I was giving a complete list in case any of them were accidental.

It's probably more useful to rerun later this year, rather than 33 hours after
release.

Hm, it looks like postgis isn't available for v12 / c6 (anymore?)

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 25 Sep 2020 15:23:13 -0500

> Hm, it looks like postgis isn't available for v12 / c6 (anymore?)

I think maybe this was never built at all.  Intentionally (?)

I see I did local compilations of it last year, to allow upgrading to v12 on
our remaining c6 servers.

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 26 Sep 2020 10:20:19 +0100

Hi,

> I think maybe this was never built at all.  Intentionally (?)

GIS stack (dependencies) cannot be built on RHEL 6 anymore.

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 27 Sep 2020 13:43:48 +0100

Hi,

> No problem, I was giving a complete list in case any of them were

Thanks for the list, btw. Christoph said 40% of the extensions cannot
be built against v13 yet. I am checking everyday for updates. 

Today pushed pg_squeeze, pgagent and pgauditlogtofile to v13.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Wed, 10 Nov 2021 16:54:24 -0600

I reran this thing to compare pg14 to pg13:

for a in 13 14; do for b in 8 7; do wget --no-check-certificate https://yum.postgresql.org/$a/redhat/rhel-$b-x86_64/ -O- |sed 's,</.*,,; s,<[^>]*>, ,g; s/-.*//; s/^ *//; s/_14$/13/; s/14/13/' |sort -u >$a-$b.dat; done; done

These are build for v14/RH8 but not v14/RH7:

-pgexporter_ext_14
-pllua_14
-postgres

These are built for pg13/RH7 but not pg14/RH7:

jsquery
pg_pathman
pgpool
pg_sampletolog
pg_squeeze13
pgstats
pguint13
pljava
pllua
PyGreSQL
redis_fdw
slony1
sqlite_fdw

Also, I found the .rpm file for postgresql14-debuginfo, but it seems like it's
not found via the centos7 repo (?)

-- 
Justin

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 16 Nov 2021 13:34:23 -0600

> not found via the centos7 repo (?)

I just realized the reason is that centos7 and 8 has no debuginfo repo at all
for pgdg14.

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Nov 2021 16:14:16 +0000

Hi Justin,

On Tue, 2021-11-16 at 13:34 -0600, Justin Pryzby wrote:
> I just realized the reason is that centos7 and 8 has no debuginfo
> repo at all for pgdg14.

I fixed this with the latest repo rpm set 10 days ago.

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Nov 2021 16:15:42 +0000

Hi Justin,

Per
https://wiki.postgresql.org/index.php?title=PostgreSQL_14_Extension_Bugs

some of these cannot be built against PostgreSQL 14, so I skipped them.
There are a few more issues like slony1 (no info about PG 14
compatibility), and PyGreSQL (definitely my mistake), etc. Fixed some
of them, will fix the rest this week.

Regards, Devrim

On Wed, 2021-11-10 at 16:54 -0600, Justin Pryzby wrote:
> for a in 13 14; do for b in 8 7; do wget --no-check-certificate
> 's,</.*,,; s,<[^>]*>, ,g; s/-.*//; s/^ *//; s/_14$/13/; s/14/13/' |sort
> -u >$a-$b.dat; done; done
>

---

From: Nicolas Thauvin <[email-masked]>
Date: Wed, 5 Jan 2022 10:48:26 +0100

On Tue, 23 Nov 2021 16:15:42 +0000
Devrim Gündüz <[email-masked]> wrote:

> some of these cannot be built against PostgreSQL 14, so I skipped
> them. There are a few more issues like slony1 (no info about PG 14

This thread says slony1 2.2.10 works with PostgreSQL 14:

https://www.slony.info/pipermail/slony1-general/2021-December/013545.html

I have tested building slony1 2.2.10 on PostgreSQL 14 using the current
specfile and it builds fine on EL-8 and EL-7. I could set up a
replication set between PostgreSQL 12 and PostgreSQL 14 on EL-8 without
any issue.

Is it enough to add it to the repositories for PostgreSQL 14?

Thanks
-- 
Nicolas Thauvin
https://dalibo.com

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 05 Jan 2022 10:58:24 +0000

Hi,

> Is it enough to add it to the repositories for PostgreSQL 14?

Thanks. Pushed packages to repos. They will sync in less than an hour.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Sat, 16 Apr 2022 20:45:27 -0500

FYI: I just noticed that neither pgfincore nor pg_repack are available for v14
(at least on centos7).

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 17 Apr 2022 20:50:31 +0100

Hi Justin,

On Sat, 2022-04-16 at 20:45 -0500, Justin Pryzby wrote:
> FYI: I just noticed that neither pgfincore nor pg_repack are
> available for v14 (at least on centos7).

$ ls -l pgfincore_14-* pg_repack_14-1.4.7-1.rhel7.x86_64.rpm 
-rw-r--r-- 1 postgres postgres  35992 Sep 22  2021 pgfincore_14-1.2.2-3.rhel7.x86_64.rpm
-rw-r--r-- 1 postgres postgres  49116 Sep 22  2021 pgfincore_14-debuginfo-1.2.2-3.rhel7.x86_64.rpm
-rw-r--r-- 1 postgres postgres 129372 Oct  4  2021 pg_repack_14-1.4.7-1.rhel7.x86_64.rpm

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Sun, 17 Apr 2022 17:15:58 -0500

> -rw-r--r-- 1 postgres postgres 129372 Oct  4  2021 pg_repack_14-1.4.7-1.rhel7.x86_64.rpm

Oh - my confusion is because the package name changed to include another
underscore.  I assume that's deliberate, and I think I knew this 6 months ago
but didn't remember.  Sorry for the noise.

pg_repack13-1.4.6-1.rhel7.x86_64
pg_repack_14-1.4.7-1.rhel7.x86_64

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 18 Apr 2022 16:54:30 +0100

Hi,

On Sun, 2022-04-17 at 17:15 -0500, Justin Pryzby wrote:
> Oh - my confusion is because the package name changed to include
> another underscore.  I assume that's deliberate, and I think I knew
> this 6 months ago but didn't remember.  Sorry for the noise.

No problem. I had to do this for consistency with all other packages.

Regards,