Subject: PG 11 with JIT/LLVM on CentOS 6 ?

From: Christophe Courtois <[email-masked]>
Date: Tue, 11 Sep 2018 18:53:28 +0200

Hi,

I can't enable JIT on PG11 on CentOS 6.

CentOS 7 contains a postgresql11-llvmjit package, that I can't find on
CentOS 6.

Is there hope to see this package soon?  I imagine some problems with
the LLVM version. Or am I missing something?

Thanks!

-- 
Christophe Courtois
Consultant Dalibo
http://dalibo.com/  -  http://dalibo.org/

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 12 Sep 2018 15:31:53 +0100

Hi,

> the LLVM version. Or am I missing something?

That is right.  LLVM (and clang) version on CentOS 6.x is not sufficient for
our LLVM support, so I disabled it on CentOS 6. 

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Christophe Courtois <[email-masked]>
Date: Wed, 12 Sep 2018 16:33:18 +0200

> our LLVM support, so I disabled it on CentOS 6. 

OK, thanks for the quick answer.
We'll live with that.