Subject: shared library version issues (yum/pgdg)

From: Justin Pryzby <[email-masked]>
Date: Wed, 27 Jun 2018 10:57:48 -0500

It looks like there's still an issue with symbol references, at least on
centos6/x86_64/pg11b1.

Perhaps postgres was compiled in one environment with a later version of
libraries - but I don't know how RPMs intend to handle that.

import _pg # pygresql
ImportError: /usr/pgsql-11/lib/libpq.so.5: symbol X509_get_signature_nid, version libcrypto.so.10 not defined in file libcrypto.so.10 with link time reference

[pryzbyj@template0 ~]$ rpm -qf /usr/lib64/libcrypto.so.10
openssl-libs-1.0.1e-60.el7_3.1.x86_64

Fixed by installing openssl-libs-1.0.2k-12.el7.x86_64.rpm

I reported several similar problems 6 months ago:

On Sat, Dec 16, 2017 at 01:01:01PM -0600, Justin Pryzby wrote:
> For centos6, I think there's an issue with the version of proj in EPEL combined
> with postgis10_24:
...
> psql:/usr/pgsql-10/share/contrib/postgis-2.4/postgis.sql:94: ERROR:  could not load library "/usr/pgsql-10/lib/postgis-2.4.so": /usr/pgsql-10/lib/postgis-2.4.so: undefined symbol: pj_get_spheroid_defn

On Tue, Jan 23, 2018 at 11:34:50AM -0600, Justin Pryzby wrote:
> Following yum update on centos6:
> InternalError: ERROR:  could not load library "/usr/pgsql-10/lib/postgis-2.4.so": /usr/pgsql-10/lib/postgis-2.4.so: undefined symbol: geod_init

On Fri, Feb 02, 2018 at 07:56:26PM -0600, Justin Pryzby wrote:
> pg_restore: [archiver (db)] Error from TOC entry 2732; 1255 16405 FUNCTION box2d_in(cstring) postgres
> pg_restore: [archiver (db)] could not execute query: ERROR:  could not load library "/usr/pgsql-9.6/lib/postgis-2.1.so": /usr/pgsql-9.6/lib/postgis-2.1.so: undefined symbol: pj_get_spheroid_defn

Thanks in advance.

Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 27 Jun 2018 17:06:25 +0100

Hi Justin,

On Wed, 2018-06-27 at 10:57 -0500, Justin Pryzby wrote:
> ImportError: /usr/pgsql-11/lib/libpq.so.5: symbol X509_get_signature_nid,
> version libcrypto.so.10 not defined in file libcrypto.so.10 with link time
> reference
> 

Hmm, looks like I need to rebuild all packages on RHEL 6 repo that depend on
OpenSSL.

I'll do it as soon as I can.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR