Subject: Missing repomd.xml.asc for postgresql 14 for RHEL 9

From: Marcin Wozniak <[email-masked]>
Date: Fri, 19 Jul 2024 11:05:31 +0000

Hi,

During our build process, we used to utilize the repomd.xml.asc package.
Once it was removed, the build process could no longer verify the public GPG key for that package due
to the missing signature.

We currently need to bypass this validation, but we are wondering if the PostgreSQL team has any plans to
reinstate the repomd.xml.asc package or if there is an upcoming release that will include it.

We regularly check for that file at: https://download.postgresql.org/pub/repos/yum/14/redhat/rhel-9-x86_64/repodata/repomd.xml.asc

Let me know if you need any further adjustments!

Thanks!

Best regards / Z poważaniem,

[VML Logo]

MARCIN WOZNIAK
IT Engineer

T 48 732 232 364
ul. Wierzbięcice 1A
Poznań
61-569
Poland

Privileged/Confidential Information may be contained in this message. If you are not the addressee indicated in this message (or responsible for delivery of the message to such person), you may not copy or deliver this message to anyone. In such case, you should destroy this message and kindly notify the sender by reply email. Please advise immediately if you or your employer does not consent to email for messages of this kind. Opinions, conclusions and other information in this message that do not relate to the official business of WPP 2005 Ltd. shall be understood as neither given nor endorsed by it.

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 19 Jul 2024 14:24:39 +0300

Hi,

On Fri, 2024-07-19 at 11:05 +0000, Marcin Wozniak wrote:
> During our build process, we used to utilize the repomd.xml.asc
> package. Once it was removed, the build process could no longer verify
> the public GPG key for that package due to the missing signature.
> 
> We currently need to bypass this validation, but we are wondering if
> the PostgreSQL team has any plans to reinstate the repomd.xml.asc
> package or if there is an upcoming release that will include it.
> 
> We regularly check for that file at:
> https://download.postgresql.org/pub/repos/yum/14/redhat/rhel-9-x86_64/repodata/repomd.xml.asc
> 
> 

It was gone for half an hour only, caused by a network issue. All files
are now back there. Sorry about that.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Marcin Wozniak <[email-masked]>
Date: Thu, 25 Jul 2024 09:56:10 +0000

Hello,
Thanks for responding and restoring that file!

Have a nice day!

[VML Logo]

MARCIN WOZNIAK
IT Engineer

T 48 732 232 364
ul. Wierzbięcice 1A
Poznań
61-569
Poland

________________________________
From: Devrim Gündüz
Sent: Friday, July 19, 2024 13:24
To: Marcin Wozniak; [email-masked]
Cc: Dawid Floryan; [email-masked]
Subject: Re: Missing repomd.xml.asc for postgresql 14 for RHEL 9

Hi,

On Fri, 2024-07-19 at 11:05 +0000, Marcin Wozniak wrote:
> https://urldefense.com/v3/__https://download.postgresql.org/pub/repos/yum/14/redhat/rhel-9-x86_64/repodata/repomd.xml.asc__;!!IfJP2Nwhk5Z0yJ43lA!Ph-BUo7lxnr2hljWWd8nm9af4GT4njF5CiF9tfhb5zt7dBRFVzbMwKC360MoNDm-foiDWvXucVFYBblPCiQ$
>
>

Regards,