Subject: pgrouting in pg 9.5

From: Scott Mugnaini <[email-masked]>
Date: Mon, 23 Nov 2015 01:33:38 +0200

On CentOS 6.5 x64:
Do you plan to include pgrouting 2.0 in pg9.5?
It is available in 9.4 and, with epel, installed without any issues.

---

From: Scott Mugnaini <[email-masked]>
Date: Sun, 10 Jan 2016 15:25:24 +0200

I've tried every permutation looking for pgrouting with CentOS 6.x64 for
PostgreSQL 9.5 and can't find it.
It is listed as an included package at
http://yum.pgrpms.org/news-packagelist.php
Am I missing something or is it simply not there?...
Scott

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 10 Jan 2016 15:59:46 +0200

Hi,

IIRC there was a build issue. Will look and let you know.

Regards,

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Mon, 11 Jan 2016 12:22:13 +0200

Hi Scott,

> Am I missing something or is it simply not there?...

AFAICS, either the boost version is not enough or the boost package
itself is broken on RHEL 6. Here is the build error:

==================================================================
CMake Error at /usr/lib64/boost/Boost.cmake:536 (message):
  The imported target "boost_date_time-static" references the file

     "/usr/lib64/lib64/libboost_date_time.a"

  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained

     "/usr/lib64/boost/Boost.cmake"

  but not all the files it references.

Call Stack (most recent call first):
  /usr/lib64/boost/BoostConfig.cmake:28 (include)
  /usr/share/cmake/Modules/FindBoost.cmake:177 (find_package)
  CMakeLists.txt:126 (find_package)

-- Configuring incomplete, errors occurred!
==================================================================

I'm about to board to plane, and will be offline for a few hours, but
per Google, this *looks like* a broken boost on RHEL 6. So, don't hold
your breath for pgrouting package on RHEL 6 for now :( Sorry about
that.

If you can upgrade to RHEL 7, pgrouting 2.1.0 is already there.

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR