Subject: pre-release packages

From: Justin Pryzby <[email-masked]>
Date: Mon, 14 Sep 2020 07:56:36 -0500

https://yum.postgresql.org/packages/#pg13
v13 PACKAGES ARE FOR BETA TESTING ONLY! USE v12 PACKAGES FOR PRODUCTION.

I think this could elaborate some, and say:
 - the beta packages are built with assertions enabled;
 - the compile options include MEMORY_CONTEXT_CHECKING, which has significant
   negative effect on performance, so packages are not useful for performance
   testing.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 17 Sep 2020 17:01:24 +0100

Hi Justin,

>    negative effect on performance, so packages are not useful for

Can you please merge these into a single sentence -- or, can you please
send a patch? The code is here:

https://git.postgresql.org/gitweb/?p=pgyum-website.git

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 17 Sep 2020 11:04:23 -0500

> send a patch? The code is here:

The beta packages are built with compile options which have significant
negative effect on performance, so packages are not useful for performance
testing.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 25 Sep 2020 16:07:41 +0100

Hi

On Thu, 2020-09-17 at 11:04 -0500, Justin Pryzby wrote:
> The beta packages are built with compile options which have
> significant negative effect on performance, so packages are not
> useful for performance testing.

This is still too long for that part, but let me see what I can do.
Pushed v14 alpha packages the other day. I'll update website on Monday,
with an information along with this info.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 25 Sep 2020 11:26:22 -0500

> with an information along with this info.

I was thinking it would go on the linked [0] page, and the text on the
*linking* page would stay the same.

[0] https://yum.postgresql.org/packages/

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 01 Oct 2020 01:02:47 +0100

Hi Justin,

> useful for performance testing.

Pushed. Does it look good now?

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Wed, 30 Sep 2020 19:05:20 -0500

> Pushed. Does it look good now?

Thanks.  I coldn't have written it better myself ;)

-- 
Justin