Subject: Mysterious package conflicts for postgresql15-15.8-1.fc40.x86_64 (Fedora 40)

From: Laurenz Albe <[email-masked]>
Date: Fri, 20 Sep 2024 09:51:22 +0200

Today, when I ran a "dnf update", I got these messages:

 Problem 1: package postgresql15-15.8-1.fc40.x86_64 from updates conflicts with postgresql provided by postgresql10-10.23-1PGDG.f37.x86_64 from @System
  - cannot install the best update candidate for package postgresql15-15.8-1PGDG.f40.x86_64
  - problem with installed package postgresql10-10.23-1PGDG.f37.x86_64
 Problem 2: package postgresql15-server-15.8-1.fc40.x86_64 from updates conflicts with postgresql-server provided by postgresql10-server-10.23-1PGDG.f37.x86_64 from @System
  - cannot install the best update candidate for package postgresql15-server-15.8-1PGDG.f40.x86_64
  - problem with installed package postgresql10-server-10.23-1PGDG.f37.x86_64
 Problem 3: package postgresql15-contrib-15.8-1.fc40.x86_64 from updates conflicts with postgresql-contrib provided by postgresql11-contrib-11.22-2PGDG.f39.x86_64 from @System
  - cannot install the best update candidate for package postgresql15-contrib-15.8-1PGDG.f40.x86_64
  - problem with installed package postgresql11-contrib-11.22-2PGDG.f39.x86_64
 Problem 4: package postgresql15-docs-15.8-1.fc40.x86_64 from updates requires postgresql15(x86-64) = 15.8-1.fc40, but none of the providers can be installed
  - package postgresql15-15.8-1.fc40.x86_64 from updates conflicts with postgresql provided by postgresql11-11.22-2PGDG.f39.x86_64 from @System
  - cannot install the best update candidate for package postgresql15-docs-15.8-1PGDG.f40.x86_64
  - problem with installed package postgresql11-11.22-2PGDG.f39.x86_64
=============================================================================================================================================================================
 Package                                           Architecture                        Version                                    Repository                            Size
=============================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 postgresql15                                      x86_64                              15.8-1.fc40                                updates                              1.7 M
 postgresql15-contrib                              x86_64                              15.8-1.fc40                                updates                              976 k
 postgresql15-server                               x86_64                              15.8-1.fc40                                updates                              6.3 M
Skipping packages with broken dependencies:
 postgresql15-docs                                 x86_64                              15.8-1.fc40                                updates                              2.2 M

I can uninstall the old PostgreSQL versions, but I would like to keep them, since
I sometimes have to investigate problems with old versions.

Is that conflict deliberate?  I admit that I don't quite understand where it comes from.

Yours,
Laurenz Albe

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 23 Sep 2024 00:00:34 +0200

On Fri, 2024-09-20 at 09:51 +0200, Laurenz Albe wrote:
> [...]

I guess the packages that didn't get installed because of a conflict
were the Fedora PostgreSQL packages.  So that is somewhat off-topic here.

The message is annoying though.  I never got such errors before.

Yours,
Laurenz Albe

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 23 Sep 2024 15:46:58 +0100

Hi,

> were the Fedora PostgreSQL packages.  So that is somewhat off-topic

Yeah, I also noticed this while working on Fedora 41 packaging. Had to
exclude postgresql in both updates-testing and updates repo. I'll see if
there is anything I can do.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR