Subject: Package issue

From: Krish Tiwary <[email-masked]>
Date: Tue, 23 Apr 2024 13:06:52 +0530

Hi,
I'm suffering from the below issue. Please assist me.

root@ip-24 ~]# sudo yum update
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 203.174.85.202
 * cpanel-addons-production-feed: 203.174.85.202
 * cpanel-plugins: 203.174.85.202
 * base: download.nus.edu.sg
 * extras: download.nus.edu.sg
 * updates: download.nus.edu.sg
EA4
                                       | 2.9 kB  00:00:00
cpanel-addons-production-feed
                                       | 2.9 kB  00:00:00
cpanel-plugins
                                        | 2.9 kB  00:00:00
base
                                        | 3.6 kB  00:00:00
extras
                                        | 2.9 kB  00:00:00
mysql-connectors-community
                                        | 2.6 kB  00:00:00
mysql-tools-community
                                       | 2.6 kB  00:00:00
mysql57-community
                                       | 2.6 kB  00:00:00
panopta.repo
                                        | 2.9 kB  00:00:00
pgdg-common/7/x86_64/signature
                                        |  665 B  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Importing GPG key 0x442DF0F8:
 Userid     : "PostgreSQL RPM Building Project <[email-masked]
>"
 Fingerprint: 68c9 e2b9 1a37 d136 fe74 d176 1f16 d2e1 442d f0f8
 Package    : pgdg-redhat-repo-42.0-35PGDG.noarch
(@/pgdg-redhat-repo-latest.noarch)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Is this ok [y/N]: y
pgdg-common/7/x86_64/signature
                                        | 2.9 kB  00:00:11 !!!
https://download.postgresql.org/pub/repos/yum/common/redhat/rhel-7-x86_64/repodata/repomd.xml:
[Errno -1] repomd.xml signature could not be verified for pgdg-common
Trying other mirror.
https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-7-x86_64/repodata/repomd.xml:
[Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use
https://bugs.centos.org/.

pgdg12/7/x86_64/signature
                                       |  665 B  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Importing GPG key 0x442DF0F8:
 Userid     : "PostgreSQL RPM Building Project <[email-masked]
>"
 Fingerprint: 68c9 e2b9 1a37 d136 fe74 d176 1f16 d2e1 442d f0f8
 Package    : pgdg-redhat-repo-42.0-35PGDG.noarch
(@/pgdg-redhat-repo-latest.noarch)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Is this ok [y/N]: y
pgdg12/7/x86_64/signature
                                       | 3.6 kB  00:00:03 !!!
https://download.postgresql.org/pub/repos/yum/12/redhat/rhel-7-x86_64/repodata/repomd.xml:
[Errno -1] repomd.xml signature could not be verified for pgdg12
Trying other mirror.
pgdg13/7/x86_64/signature
                                       |  665 B  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Importing GPG key 0x442DF0F8:
 Userid     : "PostgreSQL RPM Building Project <[email-masked]
>"
 Fingerprint: 68c9 e2b9 1a37 d136 fe74 d176 1f16 d2e1 442d f0f8
 Package    : pgdg-redhat-repo-42.0-35PGDG.noarch
(@/pgdg-redhat-repo-latest.noarch)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Is this ok [y/N]: y
pgdg13/7/x86_64/signature
                                       | 3.6 kB  00:00:07 !!!
https://download.postgresql.org/pub/repos/yum/13/redhat/rhel-7-x86_64/repodata/repomd.xml:
[Errno -1] repomd.xml signature could not be verified for pgdg13
Trying other mirror.
pgdg15/7/x86_64/signature
                                       |  665 B  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Importing GPG key 0x442DF0F8:
 Userid     : "PostgreSQL RPM Building Project <[email-masked]
>"
 Fingerprint: 68c9 e2b9 1a37 d136 fe74 d176 1f16 d2e1 442d f0f8
 Package    : pgdg-redhat-repo-42.0-35PGDG.noarch
(@/pgdg-redhat-repo-latest.noarch)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Is this ok [y/N]: y
pgdg15/7/x86_64/signature
                                       | 3.6 kB  00:00:02 !!!
https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-7-x86_64/repodata/repomd.xml:
[Errno -1] repomd.xml signature could not be verified for pgdg15
Trying other mirror.

 One of the configured repositories failed (PostgreSQL 15 for RHEL / Rocky
7 - x86_64),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the
problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a
working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=pgdg15 ...

     4. Disable the repository permanently, so yum won't use it by default.
Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable pgdg15
        or
            subscription-manager repos --disable=pgdg15

     5. Configure the failing repository to be skipped, if it is
unavailable.
        Note that yum will try to contact the repo. when it runs most
commands,
        so will have to try and fail each time (and thus. yum will be be
much
        slower). If it is a very temporary problem though, this is often a
nice
        compromise:

            yum-config-manager --save
--setopt=pgdg15.skip_if_unavailable=true

*failure: repodata/repomd.xml from pgdg15: [Errno 256] No more mirrors to
try.https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-7-x86_64/repodata/repomd.xml
<https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-7-x86_64/repodata/repomd.xml>:
[Errno -1] repomd.xml signature could not be verified for pgdg15*

Best Regards,
Krish Tiwary

3rd Floor, Plot No, 10, LSC -2,

near HDFC BANK, Sector 06,

Dwarka, Delhi, 110075

Mobile: +91 9873700947
Email: [email-masked]

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Apr 2024 13:14:18 +0100

Hi,

> I'm suffering from the below issue. Please assist me.

<snip>

Please follow the instructions in here:

https://yum.postgresql.org/news/pgdg-rpm-repo-gpg-key-update/

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR