Subject: postgis24_96 replaces postgis2_96, causing issues

From: Jimmy Angelakos <[email-masked]>
Date: Mon, 2 Oct 2017 15:44:59 +0100

Hi there,

Recently in rhel-7-x86_64, postgis24_96 replaced postgis2_96 by 
obsoleting the latter meta-package, instead of adding a 
postgis2_96-2.4.0 package.

Because some of our Geo services had version locks on postgres and 
postgis2_96, this has caused a number of problems in those services that 
colleagues are mitigating right now. Is it possible to get a 
postgis2_96-2.4.0 and to revert so that postgis24_96 does not replace 
postgis2_96?

Best regards,
Jimmy

-- 
Jimmy Angelakos
Senior Software Engineer
EDINA
Argyle House
3 Lady Lawson Street
Edinburgh
EH3 9DR
Tel: +44 (0)131 651 1557

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 05 Oct 2017 01:58:00 +0100

Hi Jimmy,

> postgis2_96-2.4.0 and to revert so that postgis24_96 does not replace 

Unfortunately, we can't revert that change, because we already started
supporting more than 1 PostGIS version for many of PG releases :(

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Jimmy Angelakos <[email-masked]>
Date: Fri, 6 Oct 2017 10:12:14 +0100

> supporting more than 1 PostGIS version for many of PG releases :(

Thanks Devrim, I've advised them to select the most specific package 
versions instead of generic ones from now on.

Cheers,
Jimmy

-- 
Jimmy Angelakos
Senior Software Engineer
EDINA
Argyle House
3 Lady Lawson Street
Edinburgh
EH3 9DR
Tel: +44 (0)131 651 1557