Subject: pgdg-redhat-repo-latest.noarch.rpm pointing to old rpm?

From: Antal Nemeš <[email-masked]>
Date: Thu, 4 Feb 2021 13:29:36 +0100

Hi,

https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-8-x86_64/pgdg-redhat-repo-latest.noarch.rpm seems to be pointing to pgdg-redhat-repo-42.0-9.noarch.rpm. 
That one still contains an enabled repo entry for 9.4 that has since been removed and is throwing 404 on all operations unless explicitly disabled.

Since one is presumably installing pgdg-redhat-repo to actually get the *.repo files, it is convenient to install it from directly by URL to -latest.noarch.rpm. To do that, the -latest should accurately reflect the latest state.

I also noticed that pgdg-redhat-repo-42.0.14 and pgdg-redhat-repo-42.0.14 are not in the 9.6/redhat/rhel-8-x86_64 repository.

Is this something that can be remedied?

Thank you and best regards,
Antal

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 09 Feb 2021 15:38:12 +0000

Hi,

On Thu, 2021-02-04 at 13:29 +0100, Antal Nemeš wrote:
> https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-8-x86_64/pgdg-redhat-repo-latest.noarch.rpm
>  seems to be pointing to pgdg-redhat-repo-42.0-9.noarch.rpm. 
> That one still contains an enabled repo entry for 9.4 that has since
> been removed and is throwing 404 on all operations unless
> explicitly disabled.

Please use this URL for downloading repo RPMs:

https://yum.postgresql.org/repopackages/

I removed all of the repo RPMs from the link you provided above. It's
been a while since I stopped pushing repo RPMs to those directories.
They are now in common dir:

https://download.postgresql.org/pub/repos/yum/common/

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR