Subject: Rsync Access

From: "Longwisch, Wilbur" <[email-masked]>
Date: Mon, 22 Jun 2026 14:55:40 +0000

We've been using rsync to mirror the postgres rpm repositories but recently rsync has stopped responding on yum.postgresql.org.  Some of the old docs mention rsync.postgresql.org but that name is no longer published either.  IIRC we switched from rsync.postgresql.org when it stopped resolving.  Has support for rsync just been dropped in favor of reposync? We can switch over to using reposync but would prefer not to if there is still a valid rsync source.

--
Wilbur Longwisch
Oak Ridge National Laboratory
ITSD Client Services

---

From: Christoph Berg <[email-masked]>
Date: Mon, 22 Jun 2026 19:45:12 +0200

Re: Longwisch, Wilbur
> We've been using rsync to mirror the postgres rpm repositories but recently rsync has stopped responding on yum.postgresql.org.  Some of the old docs mention rsync.postgresql.org but that name is n…

rsync has been shut down quite a while ago and you should switch.

Christoph

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Jun 2026 11:05:20 +0300

Hi,

On Mon, 2026-06-22 at 19:45 +0200, Christoph Berg wrote:
> > We've been using rsync to mirror the postgres rpm repositories but
> > recently rsync has stopped responding on yum.postgresql.org.  Some
> > of the old docs mention rsync.postgresql.org but that name is no
> > longer published either.  IIRC we switched from rsync.postgresql.org
> > when it stopped resolving.  Has support for rsync just been dropped
> > in favor of reposync? We can switch over to using reposync but would
> > prefer not to if there is still a valid rsync source.
> 

For details about using reposync:

https://yum.postgresql.org/using-reposync-to-mirror-pgdg-rpms/

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
BlueSky: @devrim.gunduz.org , @gunduz.org