Subject: Merge all versions of postgres

From: Martín Marqués <[email-masked]>
Date: Mon, 4 Jun 2018 09:07:26 -0300

Hi,

We had a exchange of thoughts with a co-worker regarding packaging of
rpm and apt (for some automation of package installation) and one
question we were unable to answer: Why are the pgdg repositories for
rpms separated by version?

In Debian world there's a repository for each version of
Debian/Ubuntu, but not for each version of postgres.

Is it just like that for historical reasons or is there any other
underlying issue I haven't thought of?

Kind regards,

-- 
Martín Marqués
It’s not that I have something to hide,
it’s that I have nothing I want you to see

---

From: Jason Petersen <[email-masked]>
Date: Wed, 6 Jun 2018 12:33:13 -0600

> On Jun 4, 2018, at 6:07 AM, Martín Marqués <[email-masked]> wrote:
> 
> Is it just like that for historical reasons or is there any other underlying issue I haven't thought of?

I’ve probably had this explained to me in the past, but have forgotten. Some documentation of why this is would be nice (I have a single build image for all versions of PostgreSQL on my Debian images but Red Hat stuff is the cross product of their releases and PostgreSQL and I can’t remember why; it feels like the alternatives system should make this solvable?)

--
Jason Petersen
Software Engineer | Citus Data
303.736.9255
[email-masked]

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 11 Jun 2018 00:09:20 +0300

Hi,

> rpms separated by version?

This allows us to push separate version of a same software for different
PostgreSQL versions. This could be solved by renaming all packages, adding
postgresql-11- prefix to each piece of package, but no, we are not doing that.

OTOH, I've been thinking of having a single repo file that includes all repos,
but not on top my todo list.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR