Subject: postgis for beta releases

From: Justin Pryzby <[email-masked]>
Date: Fri, 10 Jul 2020 15:04:31 -0500

Would you consider building packages during beta ?

This would allow us to do testing more easily, and I'm guessing that's true for
other people too, which leads to wider field testing.

---

From: Paul Ramsey <[email-masked]>
Date: Fri, 10 Jul 2020 13:07:18 -0700

+1

> On Jul 10, 2020, at 1:04 PM, Justin Pryzby <[email-masked]> wrote:
>

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 11 Jul 2020 17:09:12 +0100

Hi,

> Would you consider building packages during beta ?

You mean PostGIS 3.1? I thought I pushed it already :(

Built packages now. They will sync soon  to v13 testing repos. Would
you like me to build against v12 as well?

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Justin Pryzby <[email-masked]>
Date: Sat, 11 Jul 2020 11:46:20 -0500

> You mean PostGIS 3.1? I thought I pushed it already :(

I think the postgis that exists for the stable release(12) should also be built
for the beta release(13).  That allows test upgrades by 1) installing same
postgis for new postgres; and 2) pg_upgrade.

Whether to build a new version of postgis is a separate question, but if you
do, I'd suggest to build for both versions of postgres when possible.  That
allows choice of which to upgrade first.

During beta period in previous years, postgis has been the one important thing
missing.  That requires us to drop our postgis columns for beta testing.  Last
year for the first time, I instead built postgis locally on a couple servers.

I think most packages aren't built for beta, which is no problem (although I
think they sometimes needed to be added after the fact).  These are on our
list: pg_repack, fincore, libpqxx-devel.

-- 
Justin

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 21 Jul 2020 13:16:39 -0500

> you like me to build against v12 as well?

Thanks - I see that postgis31 is available for postgres13.

As I mentioned, I think postgis30 should *also* be built for v13, and postgis31
should *maybe* be built for v12:

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 28 Jul 2020 11:14:43 +0100

Hi,

> should *maybe* be built for v12:

Pushing them to v11 and v12 *testing* repos in an hour or so.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Sat, 12 Sep 2020 16:56:06 -0500

On Tue, Jul 28, 2020 at 11:14:43AM +0100, Devrim Gündüz wrote:
> > As I mentioned, I think postgis30 should *also* be built for v13, and
> > postgis31 should *maybe* be built for v12:
> 

Note, I still suggest that postgis30 and postgis31 should *both* be built for
postgres13 and (at least) postgres12.

I've done a couple test upgrades from pg12 to 13, some using pg_dump/restore,
some using pg_upgrade.  In both cases, I first had to do:

|DROP AGGREGATE st_union(geometry);
|DROP FUNCTION pgis_geometry_union_transfn;

I guess postgis30 and 31 are "compatible enough" that I was able to restore a
postgis30 DB into a DB with only postgis31 available.

Normally, I'd have to do a "rolling upgrade", either:
(pg12+gis30) => (pg12+gis31) => (pg13+gis31), or:
(pg12+gis30) => (pg13+gis30) => (pg13+gis31).

I guess this is related to postgis commit 75a044c61:

|Author: Paul Ramsey <[email-masked]>
|Date:   Fri Oct 4 18:25:46 2019 +0000
|    Restore ST_Union() aggregate signature and re-work...

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 15 Sep 2020 14:34:20 +0100

Hi Justin,

> postgres13 and (at least) postgres12.

:( Looks like you found *the* only package I forgot to move from
12testing to 12 stable repos. Just built it against v12 and v11. Will
sync them on Thursday latest, along with PG 13 rc1.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 20 May 2021 11:37:37 -0500

I'm suggesting to be build postgis31 for pg14.
It might be reasonable to wait for beta2, though.

Copying last year's correspondence for pg13.

---

From: Christoph Berg <[email-masked]>
Date: Thu, 20 May 2021 21:36:02 +0200

Re: Justin Pryzby
> It might be reasonable to wait for beta2, though.

I tried for Debian, and it fails:

postgis 3.1.1+dfsg-1.pgdg+2 (amd64)

22:58:44 gserialized_supportfn.c:420:11: error: too few arguments to function ‘is_pseudo_constant_for_index’
22:58:44   420 |      if (!is_pseudo_constant_for_index((Node*)expandexpr, req->index))
22:58:44       |           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
22:58:44 In file included from gserialized_supportfn.c:38:
22:58:44 /usr/include/postgresql/14/server/optimizer/optimizer.h:100:13: note: declared here
22:58:44   100 | extern bool is_pseudo_constant_for_index(PlannerInfo *root, Node *expr,
22:58:44       |             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~

Christoph

---

From: Christoph Berg <[email-masked]>
Date: Thu, 20 May 2021 21:36:52 +0200

Re: To Justin Pryzby
> 22:58:44   420 |      if (!is_pseudo_constant_for_index((Node*)expandexpr, req->index))

Full build log: https://pgdgbuild.dus.dg-i.net/view/Binaries-Beta/job/postgis-binaries-beta/lastFailedBuild/architecture=amd64,distribution=sid/consoleFull

Christoph

---

From: Paul Ramsey <[email-masked]>
Date: Thu, 20 May 2021 12:52:25 -0700

3.1.1 wouldn't have pg14 support yet. master branch does, and I'll backport pg14 into 3.1 branch
P

> On May 20, 2021, at 12:36 PM, Christoph Berg <[email-masked]> wrote:
> 
> Re: To Justin Pryzby

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 1 Jun 2021 18:39:25 -0500

> 3.1.1 wouldn't have pg14 support yet. master branch does, and I'll backport pg14 into 3.1 branch

I see it's available since May 21.
Devrim, would you want to build for v14 ?

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 02 Jun 2021 09:41:41 +0100

Hi,

> Devrim, would you want to build for v14 ?

I'm trying to collect a list of packages that can or cannot be compiled
against v14. Once that is complete, I will kick an initial set of
builds.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 16 Aug 2021 17:38:04 -0500

> against v14. Once that is complete, I will kick an initial set of

Would you consider building postgis for pg14b3 ?

Thanks,
-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 26 Aug 2021 16:05:21 +0100

Hi,

> Would you consider building postgis for pg14b3 ?

Done. Syncing to repos.

Cheers,

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 13 Sep 2021 21:07:04 +0100

Hi Justin,

> Would you consider building postgis for pg14b3 ?

In addition to 3.1.x, 3.2.0 alpha1 RPMs will be ready in an hour.
Please enable v14testing repo for these packages.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 19 May 2022 11:16:01 -0500

> > Would you consider building postgis for pg14b3 ?

I'm not sure if it's too early to ask, but would you consider building postgis
for pg15b1 ?

Also, could you build v15 with --enable-zstd ?

Also, it looks like there's no entry in the yum repo file for
pgdg15-updates-testing-debuginfo.

Thanks,
-- 
Justin

---

From: "Regina Obe" <[email-masked]>
Date: Thu, 19 May 2022 20:25:31 -0400

> I'm not sure if it's too early to ask, but would you consider building
postgis for
> pg15b1 ?
pgdg15-updates-
> testing-debuginfo.

Devrim and Christian  if you need a  tagged PostGIS package, I can push out
a PostGIS 3.3.0alpha1 release after I get PostGIS PSC agreement on it.
PostGIS 3.2 will not work with PostgreSQL 15.

Thanks,
Regina

---

From: Christoph Berg <[email-masked]>
Date: Fri, 20 May 2022 10:48:21 +0200

Re: Regina Obe
> PostGIS 3.2 will not work with PostgreSQL 15.

Yes that would be helpful.

The current version fails with

lwgeom_out_geojson.c:38:9: error: redeclaration of enumerator ‘JSONTYPE_NULL’
   38 |         JSONTYPE_NULL,                          /* null, so we didn't bother to identify */
      |         ^~~~~~~~~~~~~
In file included from lwgeom_out_geojson.c:21:
/usr/include/postgresql/15/server/utils/json.h:21:9: note: previous definition of ‘JSONTYPE_NULL’ with type ‘enum <anonymous>’
   21 |         JSONTYPE_NULL,                          /* null, so we didn't bother to identify */
      |         ^~~~~~~~~~~~~

Christoph

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 23 May 2022 21:11:00 +0100

Hi,

> Also, could you build v15 with --enable-zstd ?

commit 1bd03ce822dea86438ae538bdbd39600359c0133
Author: Devrim Gündüz <[email-masked]>
Date:   Thu Mar 31 12:19:30 2022 +0100
--
    PostgreSQL 15: Compile with --with-zstd to support zstd compression
of full-page writes in WAL

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 23 May 2022 15:42:03 -0500

Hmm

I think this is being evaluated as "0" for rhel, so needs to test for
suse_version > 0.

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=blob;f=rpm/redhat/main/non-common/postgresql-15/main/postgresql-15.spec;h=7da2dbc72f1cdee8003c7d71b6ccead89adc85ce;hb=3a5d4584b9c18de8c42d172032c01bfe948c8167
 640 %if 0%{?suse_version} <= 1315
 641 %else
 642         --with-zstd \
 643 %endif

postgresql15-15.0-beta1_PGDG.rhel7.x86_64

ts=# SELECT version(), setting FROM pg_config() WHERE name='CONFIGURE';
version|PostgreSQL 15beta1 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-44), 64-bit
setting| '--enable-rpath' '--prefix=/usr/pgsql-15' '--includedir=/usr/pgsql-15/include' '--mandir=/usr/pgsql-15/share/man' '--datadir=/usr/pgsql-15/share' '--libdir=/usr/pgsql-15/lib' '--with-lz4' '--enable-debug' '--enable-cassert' '--with-icu' '--with-llvm' '--with-perl' '--with-python' '--with-tcl' '--with-tclconfig=/usr/lib64' '--with-openssl' '--with-pam' '--with-gssapi' '--with-includes=/usr/include' '--with-libraries=/usr/lib64' '--enable-nls' '--enable-dtrace' '--with-uuid=e2fs' '--with-libxml' '--with-libxslt' '--with-ldap' '--with-selinux' '--with-systemd' '--with-system-tzdata=/usr/share/zoneinfo' '--sysconfdir=/etc/sysconfig/pgsql' '--docdir=/usr/pgsql-15/doc' '--htmldir=/usr/pgsql-15/doc/html' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic' 'LLVM_CONFIG=/usr/lib64/llvm5.0/bin/llvm-config' 'CLANG=/opt/rh/llvm-toolset-7/root/usr/bin/clang' 'PKG_CONFIG_PATH=:/usr/lib64/pkgconfig:/usr/share/pkgconfig' 'PYTHON=/usr/bin/python3'

postgres=# SET wal_compression =zstd;
ERROR:  invalid value for parameter "wal_compression": "zstd"
HINT:  Available values: pglz, lz4, on, off.

[pryzbyj@template0 ~]$ sudo rpm -e libzstd-1.5.2-1.el7.x86_64
error: Failed dependencies:
        libzstd >= 1.4.0 is needed by (installed) postgresql15-15.0-beta1_PGDG.rhel7.x86_64

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 31 May 2022 22:44:13 +0100

Hi Justin,

On Mon, 2022-05-23 at 15:42 -0500, Justin Pryzby wrote:
>  think this is being evaluated as "0" for rhel, so needs to test for
> suse_version > 0.
> 

<snip>

Oops... Fixed. Thanks for the report. beta1_2 packages are now syncing
to mirrors, they will be available in a couple of minutes or so.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 11 Jul 2022 12:47:08 -0500

> pgdg15-updates-testing-debuginfo.

Checking back about these parts.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 13 Jul 2022 15:09:02 +0100

Hi Justin,

> Checking back about these parts.
Done.

I had issues building 3.3 with Proj 9.0, so switched back to 8.2.  Also
wanted to push GeOS 3.11.0 first.

Meanwhile, I used this opportunity to complete GIS stack for RHEL 9 as
well.

Pushed packages for RHEL 8, 9 and Fedora, to the v15 testing
repository. There is a problem with gdal34 packaging on RHEL 7, and
I'll push RHEL 7 packages as soon as I (hopefully can) resolve it.

Regards,

---

From: "Regina Obe" <[email-masked]>
Date: Wed, 13 Jul 2022 16:25:34 -0400

Devrim,

FYI I'm in the middle of packaging PostGIS 3.3.0beta2.
So I should be done with that today.

I would like to know what kind of issues you are having building with Proj 9.0.
One of our CI bots does build with Proj 9.0/ PG15, but that's a debian bot https://github.com/postgis/postgis/runs/7328183892?check_suite_focus=true  

I'm hoping to have some CI coverage for yum / CentOS in the coming months so we can catch any of these issues early.

At anyrate, no new features are enabled with Proj 9.0 on the PostGIS front so building with Proj 8+ is fine.  Main new features require GEOS 3.11.

Thanks,
Regina

> -----Original Message-----
> From: Devrim Gündüz [mailto:[email-masked]]
> Sent: Wednesday, July 13, 2022 10:09 AM
> To: Justin Pryzby <[email-masked]>
> Cc: Paul Ramsey <[email-masked]>; Christoph Berg
> <[email-masked]>; [email-masked]
> Subject: Re: postgis for beta releases
> 
> Hi Justin,
> 
> > > I'm not sure if it's too early to ask, but would you consider
> > > building postgis for pg15b1 ?
> >
> I had issues building 3.3 with Proj 9.0, so switched back to 8.2.  Also wanted
> to push GeOS 3.11.0 first.
> 
> Meanwhile, I used this opportunity to complete GIS stack for RHEL 9 as well.
> 
> Pushed packages for RHEL 8, 9 and Fedora, to the v15 testing repository.
> There is a problem with gdal34 packaging on RHEL 7, and I'll push RHEL 7
> packages as soon as I (hopefully can) resolve it.
> 
> Regards,
> 
> --
> Devrim Gündüz

---

From: "Regina Obe" <[email-masked]>
Date: Wed, 13 Jul 2022 23:26:02 -0400

FYI released:

https://postgis.net/2022/07/13/postgis-3.3.0beta2/

Thanks,
Regina

> From: Regina Obe [mailto:[email-masked]]
> Sent: Wednesday, July 13, 2022 4:26 PM
> To: 'Devrim Gündüz' <[email-masked]>; 'Justin Pryzby'
> <[email-masked]>
> Cc: 'Paul Ramsey' <[email-masked]>; 'Christoph Berg'
> <[email-masked]>; [email-masked]' <pgsql-pkg-
> [email-masked]>
> Subject: RE: postgis for beta releases
> 
> Devrim,
> 
> One of our CI bots does build with Proj 9.0/ PG15, but that's a debian bot
> https://github.com/postgis/postgis/runs/7328183892?check_suite_focus=tru
> e
> 
> I'm hoping to have some CI coverage for yum / CentOS in the coming months
> so we can catch any of these issues early.
> 
> At anyrate, no new features are enabled with Proj 9.0 on the PostGIS front so
> building with Proj 8+ is fine.  Main new features require GEOS 3.11.
> 
> Thanks,
> Regina
> 
> 
> > I had issues building 3.3 with Proj 9.0, so switched back to 8.2.
> > Also wanted to push GeOS 3.11.0 first.
> >
> > There is a problem with gdal34 packaging on RHEL 7, and I'll push RHEL
> > 7 packages as soon as I (hopefully can) resolve it.
> >
> > Regards,
> >
> > --
> > Devrim Gündüz

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 18 Aug 2022 08:38:37 -0500

> > Checking back about these parts.

Thanks.  Few things:

I don't know if the updated repo package with debuginfo is pushed (for rh7).
I just had to manually add the pg15 debuginfo repo.

Also, I think the beta packages should be built with -Og rather than -O2.
cassert will make it slower than debug would make it faster anyway.

Also, I think that postgis32 should be built for pg15.  This allows installing
the same package for both old and new postgres versions before doing
pg_upgrade.

-- 
Justin

---

From: "Regina Obe" <[email-masked]>
Date: Thu, 18 Aug 2022 13:33:40 -0400

> Also, I think that postgis32 should be built for pg15.  This allows
installing the
> same package for both old and new postgres versions before doing
> pg_upgrade.
This is not needed anymore since PostGIS 3, since the lib file no longer has
the minor.
So doing pg_upgrade from PostgreSQL x 3.2 straight to PostgreSQL 15 3.3.0
will work just fine.

For regression testing,  it's useful.

We are planning to release PostGIS 3.3.0 before the end of this month.

Thanks,
Regina

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 19 Aug 2022 08:54:05 +0100

Hi Regina,

> I would like to know what kind of issues you are having building with

Sorry for the late reply. I fixed it a couple of days ago: It was a
spec file issue.

Thanks!

Cheers,

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 19 Aug 2022 09:10:34 +0100

Hi,

On Thu, 2022-08-18 at 08:38 -0500, Justin Pryzby wrote:
> I don't know if the updated repo package with debuginfo is pushed
> (for rh7). I just had to manually add the pg15 debuginfo repo.

Oops. Great catch. Fix committed:

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=commit;h=2a702c50c5e5ec21fc48daff2d227e17280e38e9

(Also fixed Fedora repo RPM as well). I'll release new set of repo rpms
along with some new packages later today.

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 01 Sep 2022 21:18:50 +0100

Hi Justin,

> Checking back about these parts.

Added this a couple of weeks ago. Thanks again for heads up.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 13 Oct 2022 11:55:48 -0500

Hi Devrim

Thanks for packaging pg15 !

Do you know when postgis will be available ?  It's still only in the
"testing" repo, and I think wouldn't have compiled since beta4.

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Matti Linnanvuori <[email-masked]>
Date: Thu, 13 Oct 2022 17:40:16 +0000

Hi!

They seem to be in the https://download.postgresql.org/pub/repos/yum/15/ directory already.

Best regards, Matti Linnanvuori

From: Justin Pryzby <[email-masked]>
Date: Thursday, 13. October 2022 at 19.56
To: Devrim Gündüz <[email-masked]>
Cc: Paul Ramsey <[email-masked]>, Christoph Berg <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: postgis for beta releases
Hi Devrim

--
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 13 Oct 2022 13:56:58 -0500

I see them there for fedora and for RH8 and RH9, but not yet for RH7.

https://download.postgresql.org/pub/repos/yum/15/redhat/rhel-7-x86_64/

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 14 Oct 2022 13:40:22 +0100

Hi Justin,

> Thanks for packaging pg15 !

You are welcome!
> "testing" repo, and I think wouldn't have compiled since beta4.

Thanks for heads up. Pushed RHEL 7 packages a couple of hours ago.
Needed to make a small change in the spec file.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 14 Oct 2022 14:53:22 -0500

> Needed to make a small change in the spec file.

Thanks.  I think the v15 *.repo file is missing debuginfo, at least for
RH7.  See also pgrpms commit 2a702c50c from August.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 15 Oct 2022 15:31:13 +0100

Hi,

On Fri, 2022-10-14 at 14:53 -0500, Justin Pryzby wrote:
> I think the v15 *.repo file is missing debuginfo, at least for

Thanks for the report. Fixed in git. Will push new RPMs early next
week.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 18 Jul 2023 08:35:44 -0500

On Thu, May 19, 2022 at 11:16:01AM -0500, Justin Pryzby wrote:
> > > > against v14. Once that is complete, I will kick an initial set of builds.
> > > 

If it's not already on your list, would you consider building postgis for pg16?

Thanks,
-- 
Justin

---

From: "Regina Obe" <[email-masked]>
Date: Tue, 18 Jul 2023 12:50:39 -0400

> > postgis for pg15b1 ?
Devrim. We just released PostGIS 3.4.0beta1 tested against PG16.
Much appreciated if you can package that.

Other spatial extensions that should be ready to go too

pgRouting -- 3.5  (3.6 hasn't hit beta yet, but both should work with
PostgreSQL 16)

Paul,

Hint hint, can you please push a release of ogr_fdw.  AS I recall you
haven't released since we patched up for PG16
https://github.com/pramsey/pgsql-ogr-fdw/pull/250

Thanks,
Regina

---

From: Paul Ramsey <[email-masked]>
Date: Tue, 18 Jul 2023 09:59:29 -0700

> On Jul 18, 2023, at 9:50 AM, Regina Obe <[email-masked]> wrote:
> 

https://github.com/pramsey/pgsql-ogr-fdw/releases/tag/v1.1.4

Tagged and pubbed

P

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 19 Jul 2023 12:09:27 +0100

Hi Justin,

> If it's not already on your list, would you consider building postgis

Already started working on it. Have a small issue, will report upstream.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 19 Jul 2023 14:48:32 +0100

Hi,

> If it's not already on your list, would you consider building postgis

Committed initial spec file. Will build packages soon.

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 19 Jul 2023 14:49:13 +0100

Hi,

> https://github.com/pramsey/pgsql-ogr-fdw/releases/tag/v1.1.4

Committed spec files. Will release packages soon.

Regards,

---

From: "Regina Obe" <[email-masked]>
Date: Wed, 19 Jul 2023 10:58:06 -0400

> Committed spec files. Will release packages soon.

Much appreciated and sorry for the issues with the PostGIS release.

Thanks,
Regina

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 28 Jul 2023 07:47:57 -0500

> Committed spec files. Will release packages soon.

Thanks.  Could you build for centos7, too ?

-- 
Justin

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 7 Aug 2023 13:04:43 -0500

> Thanks.  Could you build for centos7, too ?

Checking back.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 14 Aug 2023 14:34:01 +0100

Hi Justin,

> Thanks.  Could you build for centos7, too ?

I'm considering to drop RHEL 7 support for PostgreSQL 16. That is why I
did not build it so far.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 14 Aug 2023 17:55:16 -0500

> I'm considering to drop RHEL 7 support for PostgreSQL 16. That is why I

Thanks for the info.  That's not unreasonable, but I wish I had known a
few months further in advance, allowing more time to either migrate OSes
and/or plan how to deploy it ourselves.  I'd assumed that when you built
beta packages for pg16/c7, you intended to continue building them.

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 15 Aug 2023 09:03:16 +0100

Hi,

On Mon, 2023-08-14 at 17:55 -0500, Justin Pryzby wrote:
> Thanks for the info.  That's not unreasonable, but I wish I had known
> a few months further in advance, allowing more time to either migrate
> OSes and/or plan how to deploy it ourselves.  I'd assumed that when
> you built beta packages for pg16/c7, you intended to continue building
> them.

Apologies for the inconvenience. That was indeed the plan, however
further issues building 3rd party packages and the complexity in spec
files made things harder for us. Consider all dependencies of PostGIS,
for example.

Please note that since there is a common spec file of PostgreSQL 16, you
can always build RPMS via our repo.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Mon, 16 Oct 2023 07:30:29 -0500

> RH7.  See also pgrpms commit 2a702c50c from August.

It looks like pg16 debuginfo is missing from the *.repo file for RH9.

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 17 Oct 2023 12:15:57 +0100

Hi Justin,

> It looks like pg16 debuginfo is missing from the *.repo file for RH9.

Thanks, fixed. Next time can you please either submit a bug report  
https://redmine.postgresql.org/projects/pgrpms/issues/new

or start a new thread?

Thanks!

Regards,