Subject: 9.6 Beta2 /etc/init.d script setting PGDATA to 9.5 location

From: "Nicholson, Brad (Toronto, ON, CA)" <[email-masked]>
Date: Wed, 29 Jun 2016 14:56:09 +0000

Hi,

I installed 9.6 beta2 with the following repo -  pgdg-centos96-9.6-1.noarch.rpm

The init script is still referencing 9.5 in couple of places, including PGDATA (see below).  I bumped into this when trying to do an initdb with the script on a system with 9.5 on it (which obviously failed)

grep 9.5 /etc/init.d/postgresql-9.6
# PGVERSION is the full package version, e.g., 9.5.0
# PGMAJORVERSION is major version, e.g., 9.5 (this should match PG_VERSION)
PGDATA=/var/lib/pgsql/9.5/data
PGLOG=/var/lib/pgsql/9.5/pgstartup.log

Thanks,
Brad.

---

From: Jeff Frost <[email-masked]>
Date: Wed, 29 Jun 2016 08:11:47 -0700

> 
> On Jun 29, 2016, at 7:56 AM, Nicholson, Brad (Toronto, ON, CA) <[email-masked]> wrote:
> 
> Hi,
>  

Thanks for the bug report! Will get this fixed up.

---

From: Jeff Frost <[email-masked]>
Date: Wed, 29 Jun 2016 09:18:12 -0700

> On Jun 29, 2016, at 8:11 AM, Jeff Frost <[email-masked]> wrote:
> 
>> 
>> On Jun 29, 2016, at 7:56 AM, Nicholson, Brad (Toronto, ON, CA) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>>  

updated and synced the new packages, let us know if that fixes your issue.