Subject: Red Hat Enterprise Linux 8.4 upgrade uninstalls gdal32-libs and PostGIS

From: Matti Linnanvuori <[email-masked]>
Date: Tue, 18 May 2021 09:36:23 +0300

dnf --refresh upgrade Updating Subscription Management repositories. Extra Packages for Enterprise Linux Modular 8 - x86_64 102 kB/s | 36 kB 00:00 Extra Packages for Enterprise Linux 8 - x86_64 131 kB/s | 27 kB 00:00 Extra Packages for Enterprise Linux 8 - x86_64 5.4 MB/s | 9.4 MB 00:01 PostgreSQL common RPMs for RHEL/CentOS 8 - x86_64 517 B/s | 195 B 00:00 PostgreSQL 13 for RHEL/CentOS 8 - x86_64 228 B/s | 195 B 00:00 PostgreSQL 12 for RHEL/CentOS 8 - x86_64 607 B/s | 195 B 00:00 PostgreSQL 11 for RHEL/CentOS 8 - x86_64 504 B/s | 195 B 00:00 PostgreSQL 10 for RHEL/CentOS 8 - x86_64 239 B/s | 195 B 00:00 PostgreSQL 9.6 for RHEL/CentOS 8 - x86_64 632 B/s | 195 B 00:00 Red Hat Enterprise Linux 8 for x86_64 - AppStream? <https://trac.osgeo.org/postgis/wiki/AppStream> (RPMs) 11 kB/s | 4.5 kB 00:00 Red Hat Enterprise Linux 8 for x86_64 - AppStream? <https://trac.osgeo.org/postgis/wiki/AppStream>(RPMs) 8.8 MB/s | 30 MB 00:03 Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 13 kB/s | 4.1 kB 00:00 Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 4.6 MB/s | 32 MB 00:06 Virhe: 

Ongelma 4: package gdal32-libs-3.2.2-13.rhel8.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed

cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-27.el8.x86_64
cannot install both poppler-20.11.0-2.el8.x86_64 and poppler-0.66.0-26.el8.x86_64
cannot install the best update candidate for package poppler-0.66.0-27.el8.x86_64
cannot install the best update candidate for package gdal32-libs-3.2.2-13.rhel8.x86_64

https://trac.osgeo.org/postgis/ticket/4914

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 18 May 2021 11:19:27 +0100

Hi,

On Tue, 2021-05-18 at 09:36 +0300, Matti Linnanvuori wrote:
> dnf --refresh upgrade Updating Subscription Management repositories.
> Extra Packages for Enterprise Linux Modular 8 - x86_64 102 kB/s | 36 kB
> 00:00 Extra Packages for Enterprise Linux 8 - x86_64 131 kB/s | 27 kB
> 00:00 Extra Packages for Enterprise Linux 8 - x86_64 5.4 MB/s | 9.4 MB
> 00:01 PostgreSQL common RPMs for RHEL/CentOS 8 - x86_64 517 B/s | 195 B
> 00:00 PostgreSQL 13 for RHEL/CentOS 8 - x86_64 228 B/s | 195 B 00:00
> PostgreSQL 12 for RHEL/CentOS 8 - x86_64 607 B/s | 195 B 00:00
> PostgreSQL 11 for RHEL/CentOS 8 - x86_64 504 B/s | 195 B 00:00
> PostgreSQL 10 for RHEL/CentOS 8 - x86_64 239 B/s | 195 B 00:00
> PostgreSQL 9.6 for RHEL/CentOS 8 - x86_64 632 B/s | 195 B 00:00 Red Hat
> Enterprise Linux 8 for x86_64 - AppStream? < 
> https://trac.osgeo.org/postgis/wiki/AppStream> (RPMs) 11 kB/s | 4.5 kB
> 00:00 Red Hat Enterprise Linux 8 for x86_64 - AppStream? < 
> https://trac.osgeo.org/postgis/wiki/AppStream>(RPMs) 8.8 MB/s | 30 MB
> 00:03 Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 13 kB/s |
> 4.1 kB 00:00 Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 4.6
> MB/s | 32 MB 00:06 Virhe: 
> 
> Ongelma 4: package gdal32-libs-3.2.2-13.rhel8.x86_64 requires
> libpoppler.so.78()(64bit), but none of the providers can be installed
> 

Thanks for the report. I am working on it. This will take a few hours,
because this requires both fixing RHEL 8.4 packages, and also not
breaking CentOS 8.3 packages. I will keep you updated.

Regards,

-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 18 May 2021 18:23:34 +0100

Hi,

This should now be resolved. Can you please confirm? Thanks! Devrim

On 18 May 2021 11:19:27 BST, "Devrim Gündüz" <[email-masked]> wrote:
>> cannot install the best update candidate for package
>gdal32-libs-3.2.2-
>> 13.rhel8.x86_64
>
>

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Matti Linnanvuori <[email-masked]>
Date: Wed, 19 May 2021 10:53:48 +0300

Hi!

It is indeed resolved for Red Hat Enterprise Linux 8.4. Thank you.

Best regards, Matti Linnanvuori

> On 18 May 2021, at 20.23, Devrim Gündüz <[email-masked]> wrote:
> 
> Hi,
> 
> On 18 May 2021 11:19:27 BST, "Devrim Gündüz" <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi,
> 
> https://trac.osgeo.org/postgis/wiki/AppStream <https://trac.osgeo.org/postgis/wiki/AppStream>> (RPMs) 11 kB/s | 4.5 kB
> https://trac.osgeo.org/postgis/wiki/AppStream <https://trac.osgeo.org/postgis/wiki/AppStream>>(RPMs) 8.8 MB/s | 30 MB

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 20 May 2021 00:21:09 +0100

Hi,

On Wed, 2021-05-19 at 10:53 +0300, Matti Linnanvuori wrote:
> It is indeed resolved for Red Hat Enterprise Linux 8.4. Thank you

Thanks Matti.

For the archives, GIS stack was also broken because of poppler update.
To solve this issue permanently, I added pgdg-poppler packages to our
1-year old repository mentioned here:

https://yum.postgresql.org/news/centos8-llvm-repo-is-available/

Regards,