Subject: python-dateutil in pgdg96 rhel7 repo

From: Pim Rupert <[email-masked]>
Date: Sat, 18 Feb 2017 14:07:35 +0100

Hi packagers,

I noticed that the PostgreSQL 9.6 yum repository for RHEL/CentOS 7 overwrites the 'python-dateutil' package from the RHEL/CentOS 7 base repositories with a newer version. 

It would be great if the PostgreSQL yum repository followed best practices from the Safe Repo initiative. Ideally the PostgreSQL yum repository does not obsolete stock packages. 

Best regards,

Pim Rupert

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 19 Feb 2017 13:38:21 +0300

Hi Pim,

On Sat, 2017-02-18 at 14:07 +0100, Pim Rupert wrote:

> I noticed that the PostgreSQL 9.6 yum repository for RHEL/CentOS 7 overwrites
> the 'python-dateutil' package from the RHEL/CentOS 7 base repositories with a
> newer version. 

Right, because the python-dateutil package provided in RHEL 7 is not sufficient
for pgadmin4. That is why I had to add ~30 dependencies to PGDG yum repo, and
-dateutil is one of them.

> It would be great if the PostgreSQL yum repository followed best practices
> from the Safe Repo initiative. Ideally the PostgreSQL yum repository does not
> obsolete stock packages. 

Actually we *try* to do that, but there are some exceptions -- like this case.

Sorry for the inconvenience. 

Regards,
-- 
Devrim Gündüz
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Pim Rupert <[email-masked]>
Date: Mon, 20 Feb 2017 10:48:33 +0100

Hi Devrim,

> On 19 Feb 2017, at 11:38, Devrim Gündüz <[email-masked]> wrote:
> 

Awesome that you try to do it. However, it only takes one exception to break with the rules. 

You probably know that it's not only annoying, but it can have pretty grave consequences for some systems if stock packages are overwritten. Perhaps you have already thought about it, but I still would like to suggest finding a solution for this problem. 

You could separate the base PostgreSQL packages (safe) from an extras repo (non-safe). For example, I (and many more) only need the PostgreSQL packages, and have no need for third-party extras such as pgadmin4.

I can offer to help if that is desired. 

Kind regards,

Pim Rupert

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 20 Feb 2017 13:44:01 +0300

Hi Pim,

On Mon, 2017-02-20 at 10:48 +0100, Pim Rupert wrote:
> You could separate the base PostgreSQL packages (safe) from an extras repo
> (non-safe). For example, I (and many more) only need the PostgreSQL packages,
> and have no need for third-party extras such as pgadmin4.

This is a good idea, however then we will lose the point behind the PostgreSQL
yum repository: We provide RPMs for both PostgreSQL itself, and the 3rd party
packages which is useful for everyone.

Please note that PostgreSQL packages also break the OS supplied PostgreSQL RPMs
;)

Regards,

---

From: Pim Rupert <[email-masked]>
Date: Mon, 20 Feb 2017 11:53:24 +0100

Hi Devrim,

> On 20 Feb 2017, at 11:44, Devrim Gündüz <[email-masked]> wrote:
> 

Yeah, I fully realise the irony. ;-)

However, I still think it may be a good idea to have two separate repositories. They can be part of the same release package, similar as the 'testing' and 'sources' repositories. You can choose to install the PostgreSQL yum repository if you want to use a specific version of PostgreSQL supplied by the vendor and remain to have the discretion to enable/disable the repo with extra 3rd party tools which may obsolete OS packages. 

I think a warning should also be in place. 

Kind regards,

Pim Rupert

---

From: Pim Rupert <[email-masked]>
Date: Thu, 2 Mar 2017 13:44:09 +0100

Hi Devrim,

Currently having the PostgreSQL yum repositories installed is really risky business because it will obsolete many stock packages apart from postgresql-server itself. This is really something you would want to avoid. 

Just checking up on the idea of issuing a warning regarding the non-safe nature of the PostgreSQL yum repository, perhaps on https://yum.postgresql.org and in the yum repo file. Perhaps it is also a good idea to provide a list of conflicting/obsoleting packages?

(Ideally this warning would not be necessary, when there would be a separation of yum repositories into safe and non-safe.)

Kind regards,

Pim Rupert

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 02 Mar 2017 15:35:49 +0000

Hi,

Can I hear some comments from other people? We never claimed that we are Safe
Repository ( https://ius.io/SafeRepo/ ), btw. We basically even overwrite the
PostgreSQL package itself :)

Regards, Devrim

On Thu, 2017-03-02 at 13:44 +0100, Pim Rupert wrote:
> Hi Devrim,
> 
> Currently having the PostgreSQL yum repositories installed is really risky
> business because it will obsolete many stock packages apart from postgresql-
> server itself. This is really something you would want to avoid. 
> 
> Just checking up on the idea of issuing a warning regarding the non-safe
> nature of the PostgreSQL yum repository, perhaps on https://yum.postgresql.or
> g and in the yum repo file. Perhaps it is also a good idea to provide a list
> of conflicting/obsoleting packages?
> 
> (Ideally this warning would not be necessary, when there would be a
> separation of yum repositories into safe and non-safe.)
> 
> Kind regards,
> 
> Pim Rupert
>