Subject: PGLOG to be based on PGDATA please

From: H Visage <[email-masked]>
Date: Wed, 16 Sep 2015 01:21:23 +0200

Goodday,

 based on my previous email, I've set my PGDATA to /Data/9.4/Bulk/
but I've also cleaned out /var/lib/pgsql/9.4 (no reason to have that) as I
expected the files to be logged related to the Bulk postgresql cluster to
/Data/9.4/Bulk.

However, the postgresql-9.4-setup have fixed values for the PGLOG and
PGUPLOG files :(

<snip>
# Log file for pg_upgrade
PGUPLOG=/var/lib/pgsql/$PGMAJORVERSION/pgupgrade.log
# Log file for initdb
PGLOG=/var/lib/pgsql/9.4/initdb.log

# Get data directory from the service file
PGDATA=`sed -n 's/Environment=PGDATA=//p' "${SERVICE_FILE}"`

</snip>

-- 
---
Hendrik Visage
Envisage Systems / Envisage Cloud Solutions
084-612-5345 or 083-675-5506
[email-masked]

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 16 Sep 2015 11:36:09 +0300

Hi,

On Wed, 2015-09-16 at 01:21 +0200, H Visage wrote:
> but I've also cleaned out /var/lib/pgsql/9.4 (no reason to have that)

Why do you think that there is no reason to have that? We need to have
a base directory for some stuff, even if you want to customize it.

Still, I think we can add PGLOG variable to service file and change
setup script to get the value from there. I'll put this in the queue
for new set of releases (likely due next month)

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Hendrik Visage <[email-masked]>
Date: Wed, 16 Sep 2015 10:44:07 +0200

Hi Devrim,

> On 16 Sep 2015, at 10:36 AM, Devrim GÜNDÜZ <[email-masked]> wrote:
> 
> Hi,
> 

I’m a big supporter of the Debian way of handling the Postgresql clusters where
you have the configuration in /etc/postgresql/<version>/<clustername>/postgresql.conf,
 the data wherever you want (like /Data/<ClusterName> )and then the postgresql user in /home/postgres
For me I then don’t want multiple initdbs’s output in the same file (it might actually be executed
concurrently with something like ansible, and then I do want the different initdb’s logs split at least per custer
as I recreate the databases for new data loadings.

---
Hendrik Visage
Envisage Systems / Envisage Cloud Solutions
084-612-5345 or 083-675-5506
[email-masked] <mailto:[email-masked]>