Subject: Red Hat Enterprise Linux 9 error with LLVM (needed by JIT) for postgresql 13.15

From: Maxime Dumont <[email-masked]>
Date: Thu, 4 Jul 2024 20:36:02 +0000

Hi,

I got this error when I try to update Postgresql 13.14 to 13.15 on Red Hat 9:

yum update postgresql13-server-13.15
Updating Subscription Management repositories.
Last metadata expiration check: 0:22:53 ago on Thu 04 Jul 2024 04:11:28 PM EDT.
Error:
Problem: problem with installed package postgresql13-llvmjit-13.14-1PGDG.rhel9.x86_64
  - package postgresql13-llvmjit-13.14-1PGDG.rhel9.x86_64 from @System requires postgresql13-server(x86-64) = 13.14-1PGDG.rhel9, but none of the providers can be installed
  - package postgresql13-llvmjit-13.14-1PGDG.rhel9.x86_64 from pgdg13 requires postgresql13-server(x86-64) = 13.14-1PGDG.rhel9, but none of the providers can be installed
  - cannot install both postgresql13-server-13.15-1PGDG.rhel9.x86_64 from pgdg13 and postgresql13-server-13.14-1PGDG.rhel9.x86_64 from @System
  - cannot install both postgresql13-server-13.15-1PGDG.rhel9.x86_64 from pgdg13 and postgresql13-server-13.14-1PGDG.rhel9.x86_64 from pgdg13
  - cannot install the best update candidate for package postgresql13-server-13.14-1PGDG.rhel9.x86_64
  - nothing provides libLLVM-17.so()(64bit) needed by postgresql13-llvmjit-13.15-1PGDG.rhel9.x86_64 from pgdg13
  - nothing provides libLLVM-17.so(LLVM_17)(64bit) needed by postgresql13-llvmjit-13.15-1PGDG.rhel9.x86_64 from pgdg13
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Can someone make the package postgresql13-llvmjit-13.15-1PGDG.rhel9.x86_64 available on Red Hat 9 please?

Thanks

Maxime Dumont
Université Laval

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 09 Jul 2024 12:56:23 +0300

Hi,

On Thu, 2024-07-04 at 20:36 +0000, Maxime Dumont wrote:
>   - package postgresql13-llvmjit-13.14-1PGDG.rhel9.x86_64 from @System
> requires postgresql13-server(x86-64) = 13.14-1PGDG.rhel9, but none of
> the providers can be installed
>   - package postgresql13-llvmjit-13.14-1PGDG.rhel9.x86_64 from pgdg13
> requires postgresql13-server(x86-64) = 13.14-1PGDG.rhel9, but none of
> the providers can be installed
>   - cannot install both postgresql13-server-13.15-1PGDG.rhel9.x86_64
> from pgdg13 and postgresql13-server-13.14-1PGDG.rhel9.x86_64 from
> @System
>   - cannot install both postgresql13-server-13.15-1PGDG.rhel9.x86_64
> from pgdg13 and postgresql13-server-13.14-1PGDG.rhel9.x86_64 from
> pgdg13
>   - nothing provides libLLVM-17.so()(64bit) needed by postgresql13-
> llvmjit-13.15-1PGDG.rhel9.x86_64 from pgdg13
>   - nothing provides libLLVM-17.so(LLVM_17)(64bit) needed by
> postgresql13-llvmjit-13.15-1PGDG.rhel9.x86_64 from pgdg13
> (try to add '--allowerasing' to command line to replace conflicting
> packages or '--skip-broken' to skip uninstallable packages or '--
> nobest' to use not only best candidate packages)
> 
> Can someone make the package postgresql13-llvmjit-13.15-
> 1PGDG.rhel9.x86_64 available on Red Hat 9 please?

Package is available. See the error message. You also need to update
LLVM package to be able to use the latest minor versions.

Regards,

-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Zaid Shabbir <[email-masked]>
Date: Wed, 10 Jul 2024 08:24:55 +0500

Hello Devrim,

Its llvm compatibility issue on RHEL 9. Which RHEL 9 version are you using ?

---

From: Qasim Tahir <[email-masked]>
Date: Wed, 10 Jul 2024 10:36:42 +0500

Hello,

Please use the below command to update

yum update postgresql13-server-13.15 postgresql13-llvmjit-13.15

This will update postgresql13-server-13.15 smoothly

Regards,
Qasim

---

From: Maxime Dumont <[email-masked]>
Date: Wed, 10 Jul 2024 12:24:31 +0000

Hi Qasim,

Same error as before for “yum update postgresql13-server-13.15 postgresql13-llvmjit-13.15”.
I am on RHEL 9.3 and the LLVM-libs is stuck at 16.0.6. We cannot update it to 17.0.6 and we don’t know why.
We are close to open a support ticket.

On RHEL 9.4, LLVM-libs is at version 17.0.6 and I don’t have the issue to update postgresql13-server and postgresql13-llvmjit to version 13.15.

Regards,

Maxime Dumont

De : Qasim Tahir <[email-masked]>
Envoyé : 10 juillet 2024 01:37
À : Zaid Shabbir <[email-masked]>
Cc : Devrim Gündüz <[email-masked]>; Maxime Dumont <[email-masked]>; [email-masked]
Objet : Re: Red Hat Enterprise Linux 9 error with LLVM (needed by JIT) for postgresql 13.15

Hello,

Regards,
Qasim

On Wed, Jul 10, 2024 at 8:25 AM Zaid Shabbir <[email-masked]<mailto:[email-masked]>> wrote:
Hello Devrim,

On Tue, Jul 9, 2024 at 2:56 PM Devrim Gündüz <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

---

From: Qasim Tahir <[email-masked]>
Date: Fri, 12 Jul 2024 12:01:20 +0500

Hi,

I am unable to reproduce the issue at my end on RHEL 9.3

It seems to me that your rhel 9.3 is unable to update through repo

I can tell you some troubleshooting attempts that you can do

1. Check that your repo on rhel 9.3 is able to connect and it points to the
latest version
2. Check that your pgdg repo is configured properly and able to get updates
from repo. you can run below command to perform

sudo rpm -Uvh https://download.postgresql.org/pub/repos/yum/reporpms/EL-9-x86_64/pgdg-redhat-repo-latest.noarch.rpm

sudo yum update postgresql13-server-13.15 postgresql13-llvmjit-13.15

 This will update LLVM-libs to 17.0.6 version also and will update
postgresql13-server to 13.15

Regards

Qasim

On Wed, Jul 10, 2024 at 5:24 PM Maxime Dumont <[email-masked]>
wrote:

> On RHEL 9.4, LLVM-libs is at version 17.0.6 and I don’t have the issue to
> update postgresql13-server and postgresql13-llvmjit to version 13.15.
>
>
>
> Regards,
>
>
>
> *Maxime Dumont*
>
>
>
> *De :* Qasim Tahir <[email-masked]>
> *Envoyé :* 10 juillet 2024 01:37
> *À :* Zaid Shabbir <[email-masked]>
> *Cc :* Devrim Gündüz <[email-masked]>; Maxime Dumont <
> [email-masked]>; [email-masked]
> *Objet :* Re: Red Hat Enterprise Linux 9 error with LLVM (needed by JIT)
> for postgresql 13.15
>
>
>
> Hello,
>

---

From: Maxime Dumont <[email-masked]>
Date: Fri, 12 Jul 2024 14:24:55 +0000

Hi,

Our servers use subscription-manager and it was stuck at release 9.3 and LLVM version 17 was not available.

With the commands “subscription-manager release --unset" and a “dnf update” I was now able to upgrade to RHEL version 9.4 and LLVM has been upgraded to 17.0.6 as expected.

Now I can update the packages postgresql13-server and postgresql13-llvmjit to version 13.15 without any problem.

Thank you all

Maxime Dumont

De : Qasim Tahir <[email-masked]>
Envoyé : 12 juillet 2024 03:01
À : Maxime Dumont <[email-masked]>
Cc : Zaid Shabbir <[email-masked]>; Devrim Gündüz <[email-masked]>; [email-masked]
Objet : Re: Red Hat Enterprise Linux 9 error with LLVM (needed by JIT) for postgresql 13.15

Hi,

It seems to me that your rhel 9.3 is unable to update through repo
I can tell you some troubleshooting attempts that you can do
1. Check that your repo on rhel 9.3 is able to connect and it points to the latest version
2. Check that your pgdg repo is configured properly and able to get updates from repo. you can run below command to perform

This will update LLVM-libs to 17.0.6 version also and will update postgresql13-server to 13.15

Regards

Qasim

On Wed, Jul 10, 2024 at 5:24 PM Maxime Dumont <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qasim,

Regards,

Maxime Dumont

De : Qasim Tahir <[email-masked]<mailto:[email-masked]>>
Envoyé : 10 juillet 2024 01:37
À : Zaid Shabbir <[email-masked]<mailto:[email-masked]>>
Cc : Devrim Gündüz <[email-masked]<mailto:[email-masked]>>; Maxime Dumont <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Objet : Re: Red Hat Enterprise Linux 9 error with LLVM (needed by JIT) for postgresql 13.15

Hello,

Regards,
Qasim

Regards,