Subject: yum install postgis23_96-2.3.4-1.rhel7.x86_64 break

From: Marko Kuosmanen <[email-masked]>
Date: Fri, 06 Apr 2018 06:56:15 +0000

PostgreSQL PostGIS yum install is broke.

Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libdapserver.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libdap.so.17()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libarmadillo.so.8()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libogdi.so.3()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libCharLS.so.1()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libgta.so.0()(64bit)
Error: Package: postgis23_96-2.3.4-1.rhel7.x86_64 (pgdg96)
           Requires: hdf5
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libnetcdf.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libfreexl.so.1()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libcfitsio.so.2()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libdapclient.so.6()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libopenjp2.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg96)
           Requires: libhdf5.so.8()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

---

From: John Harvey <[email-masked]>
Date: Fri, 6 Apr 2018 09:13:15 -0400

Hi Marko,

It looks like you do not have EPEL repos enabled.  Can you give that a try?

For EL-7, you can do either:
sudo yum install epel-release
or:
sudo yum install
https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Hope that helps!

Regards,
  -John

---

From: Marko Kuosmanen <[email-masked]>
Date: Mon, 09 Apr 2018 07:41:29 +0000

Thanks, It worked.