Subject: cannot install postgis30 / rhel7

From: Justin Pryzby <[email-masked]>
Date: Fri, 13 Sep 2019 16:39:10 -0500

$ sudo http_proxy=http://localhost:8888 yum -y install -- postgis30_11{,-client}
...
Resolving Dependencies
--> Running transaction check
---> Package postgis30_11.x86_64 0:3.0.0alpha4-2.rhel7 will be installed
--> Processing Dependency: proj61 for package: postgis30_11-3.0.0alpha4-2.rhel7.x86_64
--> Processing Dependency: libproj.so.15()(64bit) for package: postgis30_11-3.0.0alpha4-2.rhel7.x86_64
---> Package postgis30_11-client.x86_64 0:3.0.0alpha4-2.rhel7 will be installed
--> Running transaction check
---> Package proj61.x86_64 0:6.1.0-1.rhel7 will be installed
--> Processing Dependency: sqlite-libs >= 3.7 for package: proj61-6.1.0-1.rhel7.x86_64
--> Finished Dependency Resolution
Error: Package: proj61-6.1.0-1.rhel7.x86_64 (pgdg10)
           Requires: sqlite-libs >= 3.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It seems to me the build machines should verify ability install the packages,
perhaps in a chroot or similar.

Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 14 Sep 2019 18:28:37 +0300

Hi,

>  You could try using --skip-broken to work around the problem

I fixed this a couple of weeks ago in git. I am working on a major update for
GIS components (including GDAL 3.0.1, Proj 6.2, etc). I think I can finish this
work next week, and apply all updates at once.

Regards,

-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Joe McEttrick <[email-masked]>
Date: Mon, 16 Sep 2019 10:42:34 -0400

Hi Devrim,

Are you planning to fix this soon for postgis30_10-utils?

sudo yum install postgis30_10-utils
>
> ...
>
>  -> Processing Dependency: sqlite-libs >= 3.7 for package:
> proj61-6.1.0-1.rhel7.x86_64

Thanks,
Joe

On Sat, Sep 14, 2019 at 11:28 AM Devrim Gündüz <[email-masked]> wrote:

> > $ sudo http_proxy=http://localhost:8888 yum -y install --
> postgis30_11{,-
> > client}
> > ...
> > Resolving Dependencies
> > --> Processing Dependency: libproj.so.15()(64bit) for package:
> postgis30_11-
> > 3.0.0alpha4-2.rhel7.x86_64

---

From: Paul Ramsey <[email-masked]>
Date: Thu, 19 Sep 2019 15:45:54 -0700

> >  Requires: sqlite-libs >= 3.7

I'm waiting on this to do some upgrade testing as well.
Related note: cannot find any 12beta packages to test with in the repo,
wondering if I'm doing something wrong.
P.

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 19 Sep 2019 17:52:10 -0500

On Thu, Sep 19, 2019 at 03:45:54PM -0700, Paul Ramsey wrote:
> On Mon, Sep 16, 2019 at 7:42 AM Joe McEttrick <[email-masked]> wrote:
> 

They're present (but RH7 package not working for me, as mentioned in this
thread)

https://download.postgresql.org/pub/repos/yum/testing/12/redhat/rhel-7-x86_64/
postgresql12-12beta1-1PGDG.rhel7.x86_64.rpm	2019-Jun-05 21:35:14	1.7M	application/x-redhat-package-manager
postgresql12-12beta2-1PGDG.rhel7.x86_64.rpm	2019-Jun-19 18:09:18	1.7M	application/x-redhat-package-manager
postgresql12-12beta3-1PGDG.rhel7.x86_64.rpm	2019-Aug-07 22:14:27	1.7M	application/x-redhat-package-manager
postgresql12-12beta3-2PGDG.rhel7.x86_64.rpm	2019-Sep-01 21:08:47	1.7M	application/x-redhat-package-manager
postgresql12-12beta4-1PGDG.rhel7.x86_64.rpm	2019-Sep-13 15:41:22	1.7M	application/x-redhat-package-manager

https://download.postgresql.org/pub/repos/yum/testing/12/redhat/rhel-6-x86_64/
postgresql12-12beta1-1PGDG.rhel6.x86_64.rpm	2019-May-23 07:49:47	1.8M	application/x-redhat-package-manager
postgresql12-12beta2-1PGDG.rhel6.x86_64.rpm	2019-Jun-19 16:34:47	1.8M	application/x-redhat-package-manager
postgresql12-12beta3-1PGDG.rhel6.x86_64.rpm	2019-Aug-22 13:06:16	1.8M	application/x-redhat-package-manager
postgresql12-12beta4-1PGDG.rhel6.x86_64.rpm	2019-Sep-13 11:13:53	1.8M	application/x-redhat-package-manager
postgresql12-12beta4-2PGDG.rhel6.x86_64.rpm	2019-Sep-13 14:48:29	1.8M	application/x-redhat-package-manager

Note, you have to use yum --enablerepo='pgdg12-updates-testing', or set enabled=1

[pgdg12-updates-testing]
name=PostgreSQL 12 $releasever - $basearch
baseurl=https://download.postgresql.org/pub/repos/yum/testing/12/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG

Justin

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 19 Sep 2019 18:39:06 -0500

> They're present (but RH7 package not working for me, as mentioned in this

I take that back, they're working now, since postgis was updated couple days ago:

postgis30_12-utils-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:26	36.9K	application/x-redhat-package-manager
postgis30_12-gui-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:26	190.0K	application/x-redhat-package-manager
postgis30_12-debuginfo-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:26	775.5K	application/x-redhat-package-manager
postgis30_12-docs-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:25	4.4M	application/x-redhat-package-manager
postgis30_12-devel-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:25	3.1K	application/x-redhat-package-manager
postgis30_12-client-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:25	266.4K	application/x-redhat-package-manager
postgis30_12-3.0.0alpha4-4.rhel7.x86_64.rpm	2019-Sep-17 12:30:25	4.5M	application/x-redhat-package-manager

Thanks!

Justin

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 20 Sep 2019 08:13:31 -0500

> I take that back, they're working now, since postgis was updated couple days ago:

Hi, sorry for the confusion...but this is still an issue for postgis30_11 (but
12 works ok).

...

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 24 Sep 2019 22:18:42 +0100

Hi,

>            Requires: sqlite-libs >= 3.7

Pushed new updates to the repo. Can you please test?

They are in 9.4 to 11 (both stable and testing repos) and v12 (testing)
repositories.

Regards,

---

From: "James Cassell" <[email-masked]>
Date: Tue, 24 Sep 2019 18:36:16 -0400

> They are in 9.4 to 11 (both stable and testing repos) and v12 (testing)

Confirmed postgis30_11 no longer shows errors before confirming the install.

Thanks!

V/r,
James Cassell

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 24 Sep 2019 17:54:25 -0500

> They are in 9.4 to 11 (both stable and testing repos) and v12 (testing)

Confirmed I was able to install postgis30_11 (but didn't test the upgrade,
since we already worked around it to be able to install 12b4).

I think maybe the version number will sort wrong, same as the issue I reported
with postgresql12-12beta1:
|postgis30_11-3.0.0alpha4-4.rhel7.x86_64

Maybe it should be ~alpha4 or something?

On Thu, May 23, 2019 at 09:55:00AM -0500, Justin Pryzby wrote:
> I'm wondering how versioning on PGDG RPMs is intended to work.
> Yum seems to thinks that the "nightly builds" are of higher version number than
> beta.
> 
> [pryzbyj@dev ~]$ yum list --enablerepo='pgdg12-updates-testing' --showdu postgresql12
> ...
> Installed Packages
> postgresql12.x86_64                                                         12.0-devel_20190502_1PGDG.rhel7                                                         @pgdg12-updates-testing
> Available Packages
> postgresql12.x86_64                                                         12beta1-1PGDG.rhel7                                                                     pgdg12-updates-testing 
> 
> [pryzbyj@dev ~]$ sudo yum --enablerepo=pgdg12-updates-testing install postgresql12{-server,-debuginfo,-contrib} #12beta1-1PGDG.rhel7.x86_64
> Package matching postgresql12-server-12beta1-1PGDG.rhel7.x86_64 already installed. Checking for update.
> Package matching postgresql12-debuginfo-12beta1-1PGDG.rhel7.x86_64 already installed. Checking for update.
> Package matching postgresql12-contrib-12beta1-1PGDG.rhel7.x86_64 already installed. Checking for update.
> Nothing to do
> 
> I made it work like this:
> [pryzbyj@dev ~]$ sudo yum --enablerepo=pgdg12-updates-testing downgrade postgresql12{,-libs,-server,-debuginfo,-contrib}-12beta1-1PGDG.rhel7.x86_64
> 
> ..which seems to prove that's what's going on.
> 
> I recall that debian handles that using "~", like 12~beta1.
> 
> At least, it should be called 12devel and 12beta1 for consistency?  Or
> 12.0devel and 12.0beta1.

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 25 Sep 2019 09:20:38 +0100

Hi,

On Tue, 2019-09-24 at 17:54 -0500, Justin Pryzby wrote:
> > postgis30_11-3.0.0alpha4-4.rhel7.x86_64
> 

Yeah, I will fix it in v13 cycle.

Regards,

---

From: Joe McEttrick <[email-masked]>
Date: Wed, 25 Sep 2019 10:40:16 -0400

Confirm fixed for postgis30_10.

Thanks!

On Tue, Sep 24, 2019 at 6:54 PM Justin Pryzby <[email-masked]> wrote:

> > > --> Processing Dependency: sqlite-libs >= 3.7 for package:
> proj61-6.1.0-
> > > 1.rhel7.x86_64
> > postgresql12.x86_64
>    12.0-devel_20190502_1PGDG.rhel7
>                @pgdg12-updates-testing
> > Available Packages
> > postgresql12.x86_64
>    12beta1-1PGDG.rhel7
>                pgdg12-updates-testing
> >
> > [pryzbyj@dev ~]$ sudo yum --enablerepo=pgdg12-updates-testing install
> postgresql12{-server,-debuginfo,-contrib} #12beta1-1PGDG.rhel7.x86_64
> > [pryzbyj@dev ~]$ sudo yum --enablerepo=pgdg12-updates-testing downgrade
> postgresql12{,-libs,-server,-debuginfo,-contrib}-12beta1-1PGDG.rhel7.x86_64
> >

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 25 Sep 2019 16:12:37 +0100

Hi,

> Confirm fixed for postgis30_10.

Thanks for testing! I just pushed -6, which fixes a broken symlink issue
(reported by Paul Ramsey). I won't touch this for some time, I promise :-)

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 25 Sep 2019 16:21:40 +0100

Hi Paul,

> wondering if I'm doing something wrong.

https://people.planetpostgresql.org/devrim/index.php?/archives/101-Installing-PostgreSQL-12-betaRC-on-RHELCentOSFedora.html

Cheers,

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 25 Sep 2019 16:22:48 +0100

Hi,

On Fri, 2019-09-20 at 08:13 -0500, Justin Pryzby wrote:
> Hi, sorry for the confusion...but this is still an issue for postgis30_11
> (but 12 works ok).

Yeah, that update was only for v12 testing repos. The recent updates went to
all of'em.

Cheers,

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 26 Sep 2019 17:12:44 -0500

> Pushed new updates to the repo. Can you please test?

I'm trying to install on a new centos7 VM.

Some packages are built for pg10 and 11 but not yet 12, which is sucking in
pg10/11 libs, which is odd.

[pryzbyj@tecalert01 ~]$ sudo rpm -e postgresql11{,-libs,-devel}
error: Failed dependencies:
        postgresql11-devel is needed by (installed) libpqxx-devel-1:5.0.1-2.rhel7.1.x86_64
[pryzbyj@tecalert01 ~]$ sudo rpm -e postgresql10-libs
error: Failed dependencies:
        postgresql10-libs is needed by (installed) python2-psycopg2-2.8.3-1.rhel7.x86_64

Also these aren't available yet (but I assume that's known and resolved after release):

No package pgfincore12 available.
No package pg_repack12 available.

Thanks,
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 03 Oct 2019 00:18:04 +0100

Hi

> No package pgfincore12 available.

Please use pg_prewarm. pgfincore does not have v12 support (and does not
compile anywa)

> No package pg_repack12 available.

https://github.com/reorg/pg_repack/pull/207
https://github.com/reorg/pg_repack/issues/216

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Wed, 2 Oct 2019 18:37:11 -0500

> https://github.com/reorg/pg_repack/issues/216

Thanks.

For pgfincore, I don't use it to read blocks, but (very infrequently) in a
tuning query to check "if incore"...

I compiled it fine just now for HEAD (under ubuntu).

make PG_CONFIG=/usr/local/pgsql/bin/pg_config install
waiting for server to start....2019-10-02 18:33:44.409 CDT [25266] LOG:  starting PostgreSQL 13devel on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 4.9.2-10ubuntu13) 4.9.2, 64-bit
2019-10-02 18:33:44.410 CDT [25266] LOG:  listening on IPv4 address "127.0.0.1", port 5678
2019-10-02 18:33:44.492 CDT [25266] LOG:  listening on Unix socket "/tmp/.s.PGSQL.5678"
2019-10-02 18:33:44.614 CDT [25277] LOG:  database system was shut down at 2019-10-02 12:07:06 CDT
2019-10-02 18:33:44.649 CDT [25266] LOG:  database system is ready to accept connections
 done
server started
postgres=# CREATE EXTENSION pgfincore;
CREATE EXTENSION
postgres=# SELECT * FROM pgfincore('pg_class');
     relpath     | segment | os_page_size | rel_os_pages | pages_mem | group_mem | os_pages_free | databit | pages_dirty | group_dirty 
-----------------+---------+--------------+--------------+-----------+-----------+---------------+---------+-------------+-------------
 base/12708/1259 |       0 |         4096 |           26 |        26 |         1 |        196465 |         |           0 |           0
(1 row)
postgres=# SELECT version();
version | PostgreSQL 13devel on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 4.9.2-10ubuntu13) 4.9.2, 64-bit

Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 04 Oct 2019 18:33:51 +0300

Hi Justin,

> I compiled it fine just now for HEAD (under ubuntu).

Thanks for the tip. I was not aware that I was still pushing 1.1.2, where
latest version is 1.2.1 :(

Updated to 1.2.1, and added the patch:

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=commit;h=4c2b8e8ed82f3a942937948e992a86e65eb4c59c

Will release packages soon.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Sun, 31 May 2020 17:23:00 -0500

libpqxx-devel doesn't seem to exist for pg12.

I reported this last year for pg11 and previous year for pg10; now, it's
affecting pg12.  Find quoted below our prior communication.

On Thu, Dec 14, 2017 at 09:26:21PM -0600, Justin Pryzby wrote:
> On Fri, Dec 15, 2017 at 06:05:51AM +0300, Devrim Gündüz wrote:
> > On Fri, 2017-12-08 at 13:33 -0600, Justin Pryzby wrote:
> > > I compared lists of RPMs available for PG10 vs PG96 for RHEL6 and found 
> > > that these seem to be missing for PG10.  That primarily affects new
> > > installs, users who upgrade from PG10 are likely to have the PG96 PGDG
> > > repo still. 
> > >  libpqxx?
> > It is already in the repo (5.0.1-2)
> 
> Not for centos6 (nor RHEL6) ?
> https://yum.postgresql.org/10/redhat/rhel-6-x86_64/

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 01 Jun 2020 13:26:27 +0100

Hi,

> libpqxx-devel doesn't seem to exist for pg12.

Newer libpqxx releases do not build on RHEL 7, so I also stopped
building on PG releases as well.

Still, built 5.0.1 on PG12. They will sync in 1 hour.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Wed, 9 Sep 2020 20:36:42 -0500

libpqxx-devel doesn't exist for pg13 - should it ?

Copying most recent message about this package.

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 10 Sep 2020 13:08:46 +0100

Hi,

> libpqxx-devel doesn't exist for pg13 - should it ?

I just built a few packages for v13. I'll start builds next week, along
with RC1 release.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 24 Sep 2020 17:32:33 -0500

I'm still missing libpqxx, pg_repack13, and pgfincore13

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 25 Sep 2020 15:39:50 +0100

Hi Justin,

On Thu, 2020-09-24 at 17:32 -0500, Justin Pryzby wrote:
> I'm still missing libpqxx,

Pushed 7.2.0 to RHEL 8 and Fedora repos. 

>  pg_repack13

Does not work against v13:

https://github.com/reorg/pg_repack/issues/246

>  and pgfincore13

Pushed. Thanks for the heads up.

Out of curiosity: Why don't you switch to pg_prewarm?

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Fri, 25 Sep 2020 11:30:13 -0500

> Pushed 7.2.0 to RHEL 8 and Fedora repos. 

What about c7 ?

> Out of curiosity: Why don't you switch to pg_prewarm?

We talked about this last year:

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 27 Sep 2020 13:54:09 +0100

Hi,

> > Pushed 7.2.0 to RHEL 8 and Fedora repos. 

Never versions of libpqxx does not compile on RHEL 7.

Regards,

---

From: Justin Pryzby <[email-masked]>
Date: Sun, 27 Sep 2020 09:46:35 -0500

> Never versions of libpqxx does not compile on RHEL 7.

Right, I guess we went over this earlier this year.

It's no problem, since it's in earlier PGDG repos, and in EPEL, but it's odd to
me that we'll end up using PGDG11 libpqxx for another year.

BTW I noticed this looks to be a real issue ?

$ time repoclosure -n -l base -l epel -l centos-sclo-rh -r pgdg-common -r pgdg13
...
package: pgpoolAdmin-4.0.1-1.rhel7.noarch from pgdg-common
  unresolved deps:
     pgpool-II-12 >= 0:4.0.1

-- 
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 27 Sep 2020 17:22:35 +0100

Hi,

> package: pgpoolAdmin-4.0.1-1.rhel7.noarch from pgdg-common

I'm waiting for pgPool folks to release 4.2 for v13 compatibility (also
asked them if the current releases work against v13 or not)

Regards,