Subject: RE: [postgis-users] postgis_raster undefined symbol error

From: "Regina Obe" <[email-masked]>
Date: Tue, 10 Oct 2023 08:02:18 -0400

This problem usually happens if for some reason you have two versions of GEOS installed  and the older one is being loaded.

Might be a packaging issue.  I’ve cc’d the pgsql-yum mailing list for guidance.

Thanks,

Regina

From: postgis-users <[email-masked]> On Behalf Of Andy Knight via postgis-users
Sent: Tuesday, October 10, 2023 12:34 AM
To: [email-masked]
Cc: Andy Knight <[email-masked]>
Subject: [postgis-users] postgis_raster undefined symbol error

I'm trying to create a postgis_raster extension and I'm getting the following error:

CREATE EXTENSION postgis_raster;

ERROR:  could not load library "/usr/pgsql-13/lib/postgis_raster-3.so": /usr/libspatialite50/lib/libspatialite.so.8: undefined symbol: GEOSHilbertCode_r

The instance is running on Rocky 8 linux details as below;:

NAME="Rocky Linux"

VERSION="8.8 (Green Obsidian)"

postgis31_13-utils-3.1.9-1.rhel8.x86_64

postgis31_13-devel-3.1.9-1.rhel8.x86_64

postgis31_13-client-3.1.9-1.rhel8.x86_64

postgis31_13-3.1.9-1.rhel8.x86_64

postgis31_13-docs-3.1.9-1.rhel8.x86_64

postgresql13-server-13.12-1PGDG.rhel8.x86_64

---

From: Tim Kempisty <[email-masked]>
Date: Tue, 10 Oct 2023 09:12:23 -0400

All of the latest packages for Rocky/RHEL8 on PGDG have dependency problems with PostGIS, GDAL, GEOS, and GDAL's python support packages.  The closest you will get to a working combination out of the box is postgis34 + gdal36, which both use geos312.  The other combinations are built against different versions of geos, which results in your error when trying to CREATE EXTENTSION postgis_raster.  Unfortunately, the gdal36-python-tools package depends on a conflicting python support package that doesn't have the right osgeo python modules in it.  So if you need something like gdal_calc.py in your stack, postgis34 + gdal36 is still broken.  AFAIK there is no combination of GDAL + PostGIS in this repo that currently works 100%.

My own workaround was to install proj and geos (including devel packages) from the PGDG repo, then build my own gdal and postgis from the source on github.  I used proj92 and geos312, but I imagine you can get it to work with your own preferred versions of proj and geos.

-Tim

> On Oct 10, 2023, at 8:02 AM, Regina Obe <[email-masked]> wrote:
> 
> From: postgis-users <[email-masked] <mailto:[email-masked]>> On Behalf Of Andy Knight via postgis-users
> To: [email-masked] <mailto:[email-masked]>
> Cc: Andy Knight <[email-masked] <mailto:[email-masked]>>
> ERROR:  could not load library "/usr/pgsql-13/lib/postgis_raster-3.so <http://postgis_raster-3.so/>": /usr/libspatialite50/lib/libspatialite.so <http://libspatialite.so/>.8: undefined symbol: GEOSHilbertCode_r
>

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 12 Oct 2023 03:39:29 +0100

Hi,

On Tue, 2023-10-10 at 09:12 -0400, Tim Kempisty wrote:
> All of the latest packages for Rocky/RHEL8 on PGDG have dependency
> problems with PostGIS, GDAL, GEOS, and GDAL's python support
> packages. 

I believe I fixed this issue. Please see 3.6.4-4 packages.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 12 Oct 2023 11:51:42 +0100

Hi,

> I believe I fixed this issue. Please see 3.6.4-4 packages.

err. 3.6.4-5.

Regards,

---

From: Andy Knight <[email-masked]>
Date: Thu, 12 Oct 2023 14:07:54 +0100

Thanks for all the support. I've updated the rpms to the recent 3.1.9-2 and
I'm now able to create the extension.

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 13 Oct 2023 15:02:48 +0100

Hi,

On Thu, 2023-10-12 at 14:07 +0100, Andy Knight wrote:
> Thanks for all the support. I've updated the rpms to the recent 3.1.9-
> 2 and I'm now able to create the extension.

Thanks!

Regards,