Subject: pgBackrest v2.44 missing from YUM repo for RHEL 8 x86_64?

From: Greg Clough <[email-masked]>
Date: Mon, 15 Apr 2024 15:17:02 +0000

Is there a reason that pgbackrest v2.44 isn't in the YUM repo for RHEL 8 x86_64?

$sudo dnf list pgbackrest* --showduplicates
Last metadata expiration check: 1:32:03 ago on Mon 15 Apr 2024 02:10:03 PM BST.
Available Packages
pgbackrest.x86_64                2.43-1.rhel8                    pgdg-common
pgbackrest.x86_64                2.45-1.rhel8                    pgdg-common
pgbackrest.x86_64                2.46-1.rhel8                    pgdg-common
pgbackrest.x86_64                2.46-2.rhel8                    pgdg-common
pgbackrest.x86_64                2.47-1PGDG.rhel8                pgdg-common
pgbackrest.x86_64                2.48-1PGDG.rhel8                pgdg-common
pgbackrest.x86_64                2.49-1PGDG.rhel8                pgdg-common
pgbackrest.x86_64                2.50-1PGDG.rhel8                pgdg-common
pgbackrest.x86_64                2.51-1PGDG.rhel8                pgdg-common

Thanks.
Greg.

This e-mail and any attachments may contain information that is confidential and proprietary and otherwise protected from disclosure. If you are not the intended recipient of this e-mail, do not read, duplicate or redistribute it by any means. Please immediately delete it and any attachments and notify the sender that you have received it by mistake. Unintended recipients are prohibited from taking action on the basis of information in this e-mail or any attachments. The DRW Companies make no representations that this e-mail or any attachments are free of computer viruses or other defects.

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 16 Apr 2024 09:17:54 +0100

Hi Greg,

> Is there a reason that pgbackrest v2.44 isn't in the YUM repo for RHEL

I don't know / recall.

Cheers,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Greg Clough <[email-masked]>
Date: Tue, 16 Apr 2024 09:44:40 +0100

I'm guessing there's no option to add v2.44 to the repo?  It exists for
RHEL 7 and 9, but this one specific version is missing for RHEL 8 x86_64.

I'm trying to mirror an existing environment that was built from source,
and want to make zero changes where possible.

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 16 Apr 2024 10:30:08 +0100

Hi,

On Tue, 2024-04-16 at 09:44 +0100, Greg Clough wrote:
> I'm guessing there's no option to add v2.44 to the repo?  It exists
> for RHEL 7 and 9, but this one specific version is missing for RHEL 8
> x86_64.

You still can do that by checking out rev 0b396c431b of pgrpms git repo.
I'm afraid I don't want to add a older RPM with a newer build date.

Cheers,