Subject: Re:

From: Guillaume Lelarge <[email-masked]>
Date: Thu, 19 Oct 2023 19:51:18 +0200

Hello,

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 20 Oct 2023 07:59:39 +0100

Hi Guillaume,

On Thu, 2023-10-19 at 19:51 +0200, Guillaume Lelarge wrote:
> From rpm/redhat/15/postgresql-15/EL-9/postgresql-15.spec (and many
> other
> postgresql .spec files):
> 
> # These file(s) should not be packaged:
> 
> %{__rm} %{buildroot}%{pgbaseinstdir}/lib/libpgfeutils.a
> 
> I'm wondering why this library shouldn't be packaged? It is definitely
> useful for front-end clients.

This is per Fedora packaging guidelines:

https://docs.fedoraproject.org/en-US/packaging-guidelines/#packaging-static-libraries

...though it is a "should not" item. OTOH, the same guideline if we says
we need to split those files under  -static subpackage, which we don't
ship right now.

Just took a look at Fedora spec file, and they already ship these files
in -static subpackage (we ship them with -devel subpackage as of now)

libpgcommon.a
libpgcommon_shlib.a
libpgport.a
libpgport_shlib.a

but not libpgfeutils.a

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Guillaume Lelarge <[email-masked]>
Date: Fri, 20 Oct 2023 14:43:42 +0200

Hi Devrim,

First, sorry for the email with no subject. I guess I was in a hurry :)

> we need to split those files under  -static subpackage, which we don't
OK, I guess it makes sense.

> in -static subpackage (we ship them with -devel subpackage as of now)
Yeah, I saw that. I stll don't get why we ship libpgcommon static library,
but not libpgutils.

-- 
Guillaume.