Subject: dependency problem for gdal-libs and libproj

From: Fornaroli Christophe <[email-masked]>
Date: Mon, 5 Feb 2018 10:17:11 +0100

Hello,

We are using the postgresql (9.3) yum repository on CentOs 7 and we can no
longer update
our servers. The error is:

# yum update
...
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg93)
           Requires: libproj.so.12()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

libproj.so.12 is part of proj version 4.9 but the available version in the
epel repository is 4.8.

Thanks,
Christophe

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 05 Feb 2018 15:21:15 +0000

Hi,

On Mon, 2018-02-05 at 10:17 +0100, Fornaroli Christophe wrote:

> longer update our servers. The error is:

<snip>

I am pretty surprised by the number of 9.3 users, given the number of emails I
got last week.

Apologies for the breakage,  it is my fault. John is working on a fix for this.
Once he commits, I will build updated packages.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Fornaroli Christophe <[email-masked]>
Date: Mon, 5 Mar 2018 11:41:58 +0100

Hi,

The update works. Thank you.

Regards,
Christophe