Subject: SkyTools for 9.6 repository

From: Victor Yegorov <[email-masked]>
Date: Wed, 28 Sep 2016 09:39:38 +0300

Greetings.

I would like to look into PGQ on 9.6 and I cannot see `skytools` packages
in the PGDG96 yum repository.
Will they be added?

Thank you.

-- 
Victor Yegorov

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 28 Sep 2016 13:06:28 +0300

Hi,

> in the PGDG96 yum repository.

Not sure, as I have issues building the package from released tarball :-(

Any patches welcome, though.

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Victor Yegorov <[email-masked]>
Date: Wed, 28 Sep 2016 13:09:51 +0300

> Any patches welcome, though.

I can have a look.
Can you point me where repo sources are and how to provide patches, please?

-- 
Victor Yegorov

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 28 Sep 2016 13:13:42 +0300

Hi,

> I can have a look.

Great!

> Can you point me where repo sources are and how to provide patches, please?

Sources are here:

http://git.postgresql.org/gitweb/?p=pgrpms.git

Skytools for 9.6 is here:

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=tree;f=rpm/redhat/9.6/skytools

You can either provide patches via this list, or use our issue tracker
(preferred):

https://redmine.postgresql.org/projects/pgrpms/

Thanks by now!

---

From: Christoph Berg <[email-masked]>
Date: Wed, 28 Sep 2016 12:15:47 +0200

Re: Devrim Gündüz 2016-09-28 <[email-masked]>
> Any patches welcome, though.

Fwiw, I've just managed to update the Debian package to 9.6, will
submit pull requests to github with the necessary patches shortly.

That won't make the tarballs appear, though - TBH I don't exactly
remember where we got the tarball from, I guess it was some combination
of "git submodule" trickery plus invoking "make tgz". (This is one of
the packages I try not have to touch...)

Maybe you could just grab the tarball from
http://ftp.debian.org/debian/pool/main/s/skytools3/ for the time
being...

Christoph

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Christoph Berg <[email-masked]>
Date: Wed, 28 Sep 2016 12:42:24 +0200

Re: To Devrim Gündüz 2016-09-28 <[email-masked]>
> submit pull requests to github with the necessary patches shortly.

https://github.com/markokr/skytools/pull/55
https://github.com/markokr/skytools/pull/56

Christoph

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 28 Sep 2016 13:51:04 +0300

Hi,

On Wed, 2016-09-28 at 12:15 +0200, Christoph Berg wrote:
> TBH I don't exactly

Yeah, I am also trying not to touch Skytools for similar reasons. I don't like
creating tarballs myself -- That also may bring some security concerns.

Looking at https://github.com/markokr/skytools/commits/master , project is
getting very low attention in the last 2 years :-(

Regards,

---

From: Victor Yegorov <[email-masked]>
Date: Thu, 29 Sep 2016 10:54:18 +0300

> https://redmine.postgresql.org/projects/pgrpms/

https://redmine.postgresql.org/issues/1774

Please, have a look. I do not know if this a proper way to fix it, but I've
built packages here.

-- 
Victor Yegorov

---

From: Victor Yegorov <[email-masked]>
Date: Tue, 4 Oct 2016 13:11:38 +0300

2016-09-29 10:54 GMT+03:00 Victor Yegorov <[email-masked]>:

> Please, have a look. I do not know if this a proper way to fix it, but
> I've built packages here.
>

Devrim, have you had a chance to look at the SkyTools patch for 9.6?..

-- 
Victor Yegorov

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 04 Oct 2016 13:36:06 +0300

Hi Victor,

> Devrim, have you had a chance to look at the SkyTools patch for 9.6?..

Sorry, I was busy with other stuff :( I can't see any patch in the ticket, can
you please upload it there?

Thanks!

Regards,

---

From: Victor Yegorov <[email-masked]>
Date: Tue, 4 Oct 2016 16:24:56 +0300

> you please upload it there?

Not sure how I missed to attach the patch. Done now.

-- 
Victor Yegorov

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 08 Oct 2016 18:09:06 +0300

Hi Victor,

> Not sure how I missed to attach the patch. Done now.

Wow, impressive! Thank you *very* much for the patch. Pushed packages to 9.6
testing repo. Packages will appear in next hour.

dnf (or yum) --enablerepo pgdg96-updates-testing install skytools-96

will do the trick. All tests are welcome.

Regards,