Subject: Fwd: Pre-release 2.5.0-alpha

From: Vicky Vergara <[email-masked]>
Date: Fri, 25 Aug 2017 06:43:51 -0500

Hello All.

pgRouting team is pleased to announce that the PRE-release 2.5.0-alpha Its
ready for testing.

You can download from:
https://github.com/pgRouting/pgrouting/releases/tag/v2.5.0-alpha

tests have being done also with postgreSQL 10

Regards

pgRouting team

See the pre-release documentation at:
http://docs.pgrouting.org/2.5/en/index.html
See the list of closed issues:
https://github.com/pgRouting/pgrouting/issues?utf8=%E2%9C%
93&q=milestone%3A%22Release%202.5.0%22
Breaking change on:

   -

   pgr_edgeDisjointPaths:
       Added `path_id`, `cost` and `agg_cost` columns on the result
       Parameter names changed
       The many version results are the union of the one to one version

New Signatures:

   - pgr_bdAstar(one to one)

New Proposed functions

   - pgr_bdAstar(one to many)
   - pgr_bdAstar(many to one)
   - pgr_bdAstar(many to many)
   - pgr_bdAstarCost(one to one)
   - pgr_bdAstarCost(one to many)
   - pgr_bdAstarCost(many to one)
   - pgr_bdAstarCost(many to many)
   - pgr_bdAstarCostMatrix
   - pgr_bdDijkstra(one to many)
   - pgr_bdDijkstra(many to one)
   - pgr_bdDijkstra(many to many)
   - pgr_bdDijkstraCost(one to one)
   - pgr_bdDijkstraCost(one to many)
   - pgr_bdDijkstraCost(many to one)
   - pgr_bdDijkstraCost(many to many)
   - pgr_bdDijkstraCostMatrix
   - pgr_lineGraph
   - pgr_connectedComponents
   - pgr_strongComponents
   - pgr_biconnectedComponents
   - pgr_articulationPoints
   - pgr_bridges

enhancement:

   -

   pgr_version is now on SQL language

Deprecated Signatures

   - pgr_bdastar - use pgr_bdAstar instead

Renamed Functions

   - pgr_maxFlowPushRelabel - use pgr_pushRelabel instead
   - pgr_maxFlowEdmondsKarp -use pgr_edmondsKarp instead
   - pgr_maxFlowBoykovKolmogorov - use pgr_boykovKolmogorov instead
   - pgr_maximumCardinalityMatching - use pgr_maxCardinalityMatch instead

Deprecated function

   - pgr_pointToEdgeNode

-- 

Georepublic UG (haftungsbeschränkt)
Salzmannstraße 44,
81739 München, Germany

Vicky Vergara
Operations Research

eMail: [email-masked]
Web: https://georepublic.info

Tel: +49 (089) 4161 7698-1
Fax: +49 (089) 4161 7698-9

Commercial register: Amtsgericht München, HRB 181428
CEO: Daniel Kastl

-- 

Georepublic UG (haftungsbeschränkt)
Salzmannstraße 44,
81739 München, Germany

Vicky Vergara
Operations Research

eMail: [email-masked]
Web: https://georepublic.info

Tel: +49 (089) 4161 7698-1
Fax: +49 (089) 4161 7698-9

Commercial register: Amtsgericht München, HRB 181428
CEO: Daniel Kastl

---

From: Vicky Vergara <[email-masked]>
Date: Fri, 25 Aug 2017 06:45:58 -0500

Hello All.

You can download from:

Regards

pgRouting team

See the pre-release documentation at:
http://docs.pgrouting.org/2.5/en/index.html
See the list of closed issues:
https://github.com/pgRouting/pgrouting/issues?utf8=%E2%9C%93
&q=milestone%3A%22Release%202.5.0%22
Breaking change on:

   -

   pgr_edgeDisjointPaths:

New Signatures:

New Proposed functions

enhancement:

   -

Deprecated Signatures

Renamed Functions

Deprecated function

   - pgr_pointToEdgeNode

-- 

Vicky Vergara
Operations Research