Subject: Who and How is responsible for released installations packages and 3rd party packs? (e.g. on https://yum.postgresql.org/9.6/redhat/rhel-7.3-x86_64/)

From: Alexandru Lazarev <[email-masked]>
Date: Thu, 2 Aug 2018 08:53:15 +0300

Hi PG Community,

In my company I found that PG Installation on deployed OS Images are takne
from here: https://yum.postgresql.org/9.6/redhat/rhel-7.3-x86_64/

We are using PG 9.6.5 or 9.6.7 + pgpool + plv8 + others

Some or RPMs for CentOS are taken from that URL (PG Installation, plv8).

My question is:
Who is building RPMs and uploading to that URL? What are the criteria to
build one RPM or other and their versions?
Why I am asking:
I saw on URL there are PG 9.6.8 and 9.6.9 - Are there maintained only
latest 2 build releases?

plv8 - there are versions 2.0.0-1 and 2.1.0, since latest plv8 are already
2.3.7 and latest for 2.1.X is 2.1.3 contating major fixes

Thanks,
AlexL

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 2 Aug 2018 05:47:59 -0700

On 08/01/2018 10:53 PM, Alexandru Lazarev wrote:
> Hi PG Community,
> 
> In my company I found that PG Installation on deployed OS Images are 
> takne from here: https://yum.postgresql.org/9.6/redhat/rhel-7.3-x86_64/
> 

https://www.postgresql.org/download/linux/redhat/

https://yum.postgresql.org/

> plv8 - there are versions 2.0.0-1 and 2.1.0, since latest plv8 are 
> already 2.3.7 and latest for 2.1.X is 2.1.3 contating major fixes
> 
> 
> Thanks,
> AlexL

-- 
Adrian Klaver
[email-masked]

---

From: Alexandru Lazarev <[email-masked]>
Date: Thu, 2 Aug 2018 16:26:38 +0300

What about 3rd party libraries like plv8 - Who and How (based on which
criteria, which versions) build RPM and upload them there?

+ adding more relevant mail list

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 03 Aug 2018 09:08:55 +0300

Hi,

> criteria, which versions) build RPM and upload them there?

Latest versions of PL/v8 does not build on RHEL/Fedora anymore, at least from
the package build point of view. RPMs are not supposed to download extra
dependencies from elsewhere.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Christoph Berg <[email-masked]>
Date: Fri, 3 Aug 2018 10:22:23 +0200

Re: Devrim Gündüz 2018-08-03 <[email-masked]>
> dependencies from elsewhere.

Fwiw, I stopped maintaining plv8 in Debian for that reason. The build
process is roughly equivalent to downloading all of chromium's
dependencies, and build v8 from that. v8 is no longer a shared
library, unfortunately.

Christoph

---

From: Pavel Raiskup <[email-masked]>
Date: Fri, 03 Aug 2018 10:30:51 +0200

On Friday, August 3, 2018 8:08:55 AM CEST Devrim Gündüz wrote:
> the package build point of view.

Yes, packaging of plv8 is pretty complicated.  If one decided to ship RPM
package with plv8, it would mean maintenance of whole v8 language - which
is incredibly complicated (incompatible changes all the time, backporting
security fixes, etc.).

That's the reason why plv8 (and even v8 runtime) becomes dropped from Linux
distributions.

[1] https://github.com/plv8/plv8/issues/281

Pavel

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 06 Aug 2018 00:02:49 +0300

Hi,

> I saw on URL there are PG 9.6.8 and 9.6.9 - Are there maintained only

Yes, older releases are deleted automagically.

Regards,

---

From: Alexandru Lazarev <[email-masked]>
Date: Mon, 6 Aug 2018 23:49:08 +0300

Thanks all for responses.

Let me ask other dummy question:
plv8 RPMs were built by PostgreSQL Community for different OSes, or by
those OSes vendors/community (e.f. RedHat/Debian, etc)?
And the same question about postgresql-server install packages themselves
(RPMs, debs, etc)

Thanks in advance

---

From: Alexandru Lazarev <[email-masked]>
Date: Mon, 6 Aug 2018 23:51:32 +0300

Thanks in advance

---

From: Dimitri Maziuk <[email-masked]>
Date: Mon, 6 Aug 2018 15:57:04 -0500

> And the same question about postgresql-server install packages themselves

For this one, packages you get from "PGDG"@
https://www.postgresql.org/download/ are built by postgres. RedHat, for
example, also has postgres built by them and included in the
distribution -- in RHEL7 it's v.9.2 but RedHat is known to patch code
without changing version numbers.

-- 
Dimitri Maziuk
Programmer/sysadmin
BioMagResBank, UW-Madison -- http://www.bmrb.wisc.edu

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 06 Aug 2018 22:38:38 +0100

Hi,

> And the same question about postgresql-server install packages themselves

There are community RPMs, and then the RPMs supplied by Red Hat / CentOS  via OS or SCL.

Community packages has wider range of supported PostgreSQL versions, and wider range of packages.

Regards,

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 10 Aug 2018 15:22:05 -0400

> That's the reason why plv8 (and even v8 runtime) becomes dropped from Linux

Uh, who is building PL/v8 currently, and for what operating systems?  No one?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +

---

From: Christoph Berg <[email-masked]>
Date: Fri, 10 Aug 2018 21:41:44 +0200

Re: Bruce Momjian 2018-08-10 <[email-masked]>
> Uh, who is building PL/v8 currently, and for what operating systems?  No one?

No one is likely correct.

Christoph

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 10 Aug 2018 15:44:07 -0400

> No one is likely correct.

Wow, OK.  That's bad news.  So PL/v8 is no longer a viable stored
procedure language?

---

From: Christoph Berg <[email-masked]>
Date: Fri, 10 Aug 2018 21:49:03 +0200

Re: Bruce Momjian 2018-08-10 <[email-masked]>
> Wow, OK.  That's bad news.  So PL/v8 is no longer a viable stored

It is bad news, the plv8 upstream is very pleasant to work with.

But now building plv8 means building v8 first, which means something
like downloading and building the whole chrome toolchain. That's 30 GB
of stuff, including binary blobs from the internet.

plv8 will work for anyone willing to go through that. It's just not
feasible to support it from a packager perspective.

Christoph

---

From: Dimitri Maziuk <[email-masked]>
Date: Fri, 10 Aug 2018 15:38:16 -0500

> feasible to support it from a packager perspective.

Hm. Gotta wonder if running this:
https://github.com/clkao/docker-postgres-plv8/blob/master/10-2/Dockerfile
and copying plv8.so out of the resulting image is the easy way out.

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 11 Aug 2018 15:39:33 +0100

Hi,

> feasible to support it from a packager perspective.

+1 from me.

Regards,