Subject: getting rhel7 packages instead of rhel6 packages

From: Sebastian Steuer <[email-masked]>
Date: Thu, 8 Sep 2016 13:50:47 +0100

Hi,

when using repository config from this package:
Amazon Linux AMI 2015.03 - x86_64
https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-x86_64/pgdg-ami201503-93-9.3-2.noarch.rpm

i'm getting *.PGDG.rhel7.x86_64 instead of PGDG.rhel6.x86_64

that breaks things as these packages do not exist in:
https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-x86_64

also if they would some will require systemd

i believe repodata is broken

kind regards
Sebastian

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 08 Sep 2016 17:18:13 +0300

Hi,

> i believe repodata is broken

AFAICS from the .repo file in git repo, they all point to RHEL6 directory:

https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-x86_64/

Can you please paste contents of .repo file under /etc/yum.reposs.d/pgdg-93-
ami201503.repo ?

Thanks!

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Sebastian Steuer <[email-masked]>
Date: Thu, 8 Sep 2016 15:25:40 +0100

Hi,

it is correct

# cat /etc/yum.repos.d/pgdg-93-ami201503.repo
[pgdg93]
name=PostgreSQL 9.3 - Amazon Linux AMI 2015.03 - $basearch
baseurl=
https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-93

[pgdg93-source]
name=PostgreSQL 9.3 Amazon Linux AMI 2015.03 - $basearch - Source
failovermethod=priority
baseurl=
https://download.postgresql.org/pub/repos/yum/srpms/9.3/redhat/rhel-6-$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-93

On Thu, Sep 8, 2016 at 3:18 PM, Devrim Gündüz <[email-masked]> wrote:

> > https://download.postgresql.org/pub/repos/yum/9.3/redhat/
> rhel-6-x86_64/pgdg-a
> > mi201503-93-9.3-2.noarch.rpm
> >

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 08 Sep 2016 17:41:23 +0300

Hi,

> https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-$basearch

Ok, but there are not RHEL 7 packages in this directory. Can you please make
sure that there are no more .repo files in this directory that includes PGDG
stuff in it?

Thanks!

Regards,

---

From: Sebastian Steuer <[email-masked]>
Date: Thu, 8 Sep 2016 16:00:57 +0100

Hi,

there is no other PGDG repositories configured on that system. In fact
there are only amazon repositories + the repo file i've already pasted to
you.
but i realized it was yum cache
it had pgdg93 repository before and it had things cached that confused yum

did yum clean all and it works now

sorry for that

kind regards
Sebastian

On Thu, Sep 8, 2016 at 3:41 PM, Devrim Gündüz <[email-masked]> wrote:

> rhel-6-$basearch