Subject: postgresql94 doesn't add pg_config to alternatives system

From: Yuri Kanivetsky <[email-masked]>
Date: Thu, 7 Sep 2017 23:02:08 +0300

Hi,

By that I mean the following:

$ rpm -q --scripts postgresql94 | egrep 'psql|pg_config'
/usr/sbin/update-alternatives --install /usr/bin/psql pgsql-psql
/usr/pgsql-9.4/bin/psql 940
...

As a result, psql is available right away after installing the
package. But not so with pg_config. Is it by design or by accident?

More info here:
https://serverfault.com/questions/872537/can-i-use-pg-config-of-other-version-of-postgresql#872537

Regards,
Yuri

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 13 Sep 2017 16:33:19 +0100

Hi Yuri,

> package. But not so with pg_config. Is it by design or by accident?

This is intentional. We don't provides alternatives entries for binaries that
are not shared between multiple versions.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Yuri Kanivetsky <[email-masked]>
Date: Thu, 14 Sep 2017 01:35:08 +0300

Hi,

Can you possibly elaborate? These are the binaries for which you
provide alternatives:

psql
clusterdb
createdb
createlang
createuser
dropdb
droplang
dropuser
pg_basebackup
pg_dump
pg_dumpall
pg_restore
reindexdb
vacuumdb

Are they all binary equal for 9.x packages? For 9.x + 8.x packages? Or
they can have non-breaking changes? Or they can be used with any
PostgreSQL server of the same major version?

Regards,
Yuri

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 15 Sep 2017 00:23:49 +0100

Hi,

On Thu, 2017-09-14 at 01:35 +0300, Yuri Kanivetsky wrote:
> Are they all binary equal for 9.x packages? 

They are not *binary equal", but you can use 9.6's psql against 9.5 server, or
dump 9.5 db with 9.6's pg_dump.

That is why we keep them under /usr/bin.

Regards,